请老师帮助修改一个黄金分割线公式

[通达信]
设置
1589 2 听风戏雨 Lv.4 发表于 · 2021-4-7 10:09 显示全部楼层 正序浏览 |
跳转到指定楼层
黄金分割线公式;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWICON(BU,L-0.1,1);
DRAWICON(SEL,H+0.1,2);
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(买线<卖线,CLOSE,OPEN,2,1),COLORGREEN;
散户:EMA(CLOSE,5),COLORWHITE;
操盘:MA(CLOSE,9),COLORCYAN,LINETHICK2;
界点:MA(CLOSE,20),COLORMAGENTA;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW. CXH 99.COM '),COLORRED;
DRAWTEXT_FIX(C>O,1,1,0,''),COLORRED;
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
日:=150;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),COLORRED;
一0.809:REFDATE(H1,DATE),COLORYELLOW;
二0.618:REFDATE(H2,DATE),COLORMAGENTA;
三0.500:REFDATE(H3,DATE),COLORWHITE;
四0.382:REFDATE(H4,DATE),COLORGREEN;
五0.191:REFDATE(H5,DATE),COLORYELLOW;
低:REFDATE(低1,DATE),COLORRED;
这个公式在老版本的通达信上面可以用。后来通达信升级之后就出现问题了。。。。。 QQ图片20210407100823.png

举报

使用道具 扔鸡蛋(0) 回复

听风戏雨
Lv.4
发表于 2021-4-7 10:57 复制 查看全部楼层
学悟2020 发表于 2021-4-7 10:24
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);

谢谢学悟2020老师!

举报

使用道具 扔鸡蛋(0) 回复

学悟2020
Lv.2
发表于 2021-4-7 10:24 复制 查看全部楼层
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWICON(BU,L-0.1,1);
DRAWICON(SEL,H+0.1,2);
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(买线<卖线,CLOSE,OPEN,2,1),COLORGREEN;
散户:EMA(CLOSE,5),COLORWHITE;
操盘:MA(CLOSE,9),COLORCYAN,LINETHICK2;
界点:MA(CLOSE,20),COLORMAGENTA;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW. CXH 99.COM '),COLORRED;
DRAWTEXT_FIX(C>O,1,1,0,''),COLORRED;
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
日:=150;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),COLORRED;
一809:REFDATE(H1,DATE),COLORYELLOW;
二618:REFDATE(H2,DATE),COLORMAGENTA;
三500:REFDATE(H3,DATE),COLORWHITE;
四382:REFDATE(H4,DATE),COLORGREEN;
五191:REFDATE(H5,DATE),COLORYELLOW;
低:REFDATE(低1,DATE),COLORRED;

附件

1617762232(1).png

举报

使用道具 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表