请老师帮助做个选股公式

[通达信]
设置
1519 2 啥都第一 Lv.2 发表于 · 2021-4-7 15:55 显示全部楼层 正序浏览 |
跳转到指定楼层
老师 帮我做一个 两条线在底部金叉的选股公式
VAR3:=MA(CLOSE,13);
VAR4:=100-ABS(((CLOSE-VAR3)/(VAR3))*(100));
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6-VAR5)/(100);
VAR8:=SMA((CLOSE-VAR5)/(VAR7),20,1);
VAR9:=SMA((OPEN-VAR5)/(VAR7),20,1);
VARA:=(3)*(VAR8)-(2)*(SMA(VAR8,15,1));
VARB:=(3)*(VAR9)-(2)*(SMA(VAR9,15,1));
VARC:=100-VARB;
VARD:=(REF(LOW,1))*(0.89999997);
VARE:=(LOW)*(0.89999997);
VARF:=((VARE)*(VOL)+(VARD)*(CAPITAL-VOL))/(CAPITAL);
VAR10:=EMA(VARF,30);
VAR11:=CLOSE-REF(CLOSE,1);
VAR12:=MAX(VAR11,0);
VAR13:=ABS(VAR11);
VAR14:=((SMA(VAR12,7,1))/(SMA(VAR13,7,1)))*(100);
VAR15:=((SMA(VAR12,13,1))/(SMA(VAR13,13,1)))*(100);
VAR16:=BARSCOUNT(CLOSE);
VAR17:=((SMA(MAX(VAR11,0),6,1))/(SMA(ABS(VAR11),6,1)))*(100);
VAR18:=(((-200))*(HHV(HIGH,60)-CLOSE))/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR19:=((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15)))*(100);
VAR1A:=SMA((SMA(VAR19,4,1)-50)*(2),3,1);
VAR1B:=((INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14)))*(100);
VAR1C:=SMA(VAR1B,4,1);
VAR1D:=SMA(VAR1C,3,1);
VAR1E:=((HHV(HIGH,30)-CLOSE)/(CLOSE))*(100);
VAR1F:=((CLOSE-LLV(LOW,31))/(HHV(HIGH,31)-LLV(LOW,31)))*(100);
VAR20:=REVERSE(VAR1F);
VAR21:=SMA(VAR1F,3,1);
多线:SMA(VAR21,3,1),COLOR0000FF,LINETHICK2;
空线:SMA(多线,3,1),COLORLIBLUE,LINETHICK2;
介入:IF(CROSS(多线,空线) AND (多线<30),20,0),COLORYELLOW,LINETHICK2;
退出:IF(CROSS(空线,多线) AND (空线>75),85,100),COLOR008000,LINETHICK2;
本主题由 任务系统 于 2021-4-7 16:00 审核通过

举报

使用道具 扔鸡蛋(0) 回复

虫子1244
Lv.0
发表于 2021-4-7 17:22 复制 查看全部楼层
楼上正解 直接改介入就行

举报

使用道具 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2021-4-7 16:46 复制 查看全部楼层
VAR1F:=((CLOSE-LLV(LOW,31))/(HHV(HIGH,31)-LLV(LOW,31)))*(100);
VAR21:=SMA(VAR1F,3,1);
多线:=SMA(VAR21,3,1);
空线:=SMA(多线,3,1);
CROSS(多线,空线)&&多线<20;

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表