请老师帮助做个选股公式

[通达信]
设置
1565 3 风中点烟sh Lv.3 发表于 · 2021-4-7 19:39 显示全部楼层 正序浏览 |
跳转到指定楼层
SJTJ:=DATE<1590301;
MAH:=(H*18+REF(H,1)*17+REF(H,2)*16+REF(H,3)*15+REF(H,4)*14+REF(H,5)*13+REF(H,6)*12+REF(H,7)*11+REF(H,8)*10+REF(H,9)*9+REF(H,10)*8+REF(H,11)*7+REF(H,12)*6+REF(H,13)*5+REF(H,14)*4+REF(H,15)*3+REF(H,16)*2+REF(H,17)*1)/171;
MAL:=(L*18+REF(L,1)*17+REF(L,2)*16+REF(L,3)*15+REF(L,4)*14+REF(L,5)*13+REF(L,6)*12+REF(L,7)*11+REF(L,8)*10+REF(L,9)*9+REF(L,10)*8+REF(L,11)*7+REF(L,12)*6+REF(L,13)*5+REF(L,14)*4+REF(L,15)*3+REF(L,16)*2+REF(L,17)*1)/171;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA60:=MA(CLOSE,60);
DK:= SJTJ AND( CLOSE>=MAH OR (C>MA5 AND C>MA10 AND C>MA20 AND C>MA60));
KK:= SJTJ AND( MAL>CLOSE OR (C<MA5 AND C<MA10 AND C<MA20 AND C<MA60));
DK1:=BARSLAST(DK);
KK1:=BARSLAST(KK);
DK2:=BARSLAST(CROSS(KK1,DK1));
KK2:=BARSLAST(CROSS(DK1,KK1));
HS:=DK2<KK2;
CROSS(HS,0.5);

1、做个预警公式
2、如图将趋势共振的输出赋予x1:

举报

使用道具 扔鸡蛋(0) 回复

风中点烟sh
Lv.3
发表于 2021-4-7 20:44 复制 查看全部楼层
中.James 发表于 2021-4-7 20:40
这本身就是一个选股公式,只是加了时间限制。
SJTJ:=1;
MAH:=(H*18+REF(H,1)*17+REF(H,2)*16+REF(H,3)*15 ...

是的 谢谢老师 原先少了个输出不便和其他信号共振

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

中.James
Lv.4
发表于 2021-4-7 20:40 复制 查看全部楼层
本帖最后由 中.James 于 2021-4-7 20:43 编辑

这本身就是一个选股公式,只是加了时间限制。
SJTJ:=1;
MAH:=(H*18+REF(H,1)*17+REF(H,2)*16+REF(H,3)*15+REF(H,4)*14+REF(H,5)*13+REF(H,6)*12+REF(H,7)*11+REF(H,8)*10+REF(H,9)*9+REF(H,10)*8+REF(H,11)*7+REF(H,12)*6+REF(H,13)*5+REF(H,14)*4+REF(H,15)*3+REF(H,16)*2+REF(H,17)*1)/171;
MAL:=(L*18+REF(L,1)*17+REF(L,2)*16+REF(L,3)*15+REF(L,4)*14+REF(L,5)*13+REF(L,6)*12+REF(L,7)*11+REF(L,8)*10+REF(L,9)*9+REF(L,10)*8+REF(L,11)*7+REF(L,12)*6+REF(L,13)*5+REF(L,14)*4+REF(L,15)*3+REF(L,16)*2+REF(L,17)*1)/171;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA60:=MA(CLOSE,60);
DK:= SJTJ AND( CLOSE>=MAH OR (C>MA5 AND C>MA10 AND C>MA20 AND C>MA60));
KK:= SJTJ AND( MAL>CLOSE OR (C<MA5 AND C<MA10 AND C<MA20 AND C<MA60));
DK1:=BARSLAST(DK);
KK1:=BARSLAST(KK);
DK2:=BARSLAST(CROSS(KK1,DK1));
KK2:=BARSLAST(CROSS(DK1,KK1));
HS:=DK2<KK2;
X1:CROSS(HS,0.5);


说点个人看法,不要沉迷于此类垃圾公式。多研究传统的指标,如MACD等,多看点经典的书籍。

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

风中点烟sh
Lv.3
发表于 2021-4-7 20:19 复制 查看全部楼层
预警的有了 只要做选股时的输出x1就好 忘附图了

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表