请老师帮助编写个均量线公式

[通达信]
设置
1242 7 紫外线r Lv.2 发表于 · 2021-4-8 13:11 显示全部楼层 正序浏览 |
跳转到指定楼层
求助哪位大神,把最下面的量柱给写个量均线的源码呗,两条线分别是5日量均线和10日量均线,先谢谢啦


[attachimg]

附件

QQ图片20210408132015.jpg

举报

使用道具 扔鸡蛋(0) 回复

紫外线r
Lv.2
发表于 2021-4-8 22:43 复制 查看全部楼层
㊣会飞的鱼 发表于 2021-4-8 20:45
成交额:AMO/100000000,COLORRED,NODRAW;
量:VOL,VOLSTICK;
V5:MA(量,5),COLORWHITE;

妈呀,太谢谢老师啦

没想到您有帮我重新帮我解决了问题

这回加上了

感恩,真心谢谢,愿好人一生平安

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

㊣会飞的鱼
Lv.3
发表于 2021-4-8 20:45 复制 查看全部楼层
成交额:AMO/100000000,COLORRED,NODRAW;
量:VOL,VOLSTICK;
V5:MA(量,5),COLORWHITE;
V10:MA(量,10),COLORMAGENTA;
换手:VOL*100/CAPITAL,NODRAW;
几倍:V/REF(V,1),COLORMAGENTA,NODRAW;
流通市值:FINANCE(40)/100000000,NODRAW;
{标记特殊成交量}
NOYZ:=NOT(C/REF(C,1)>1.095 AND H=O AND L=H);
均价:SUM(AMOUNT,1)/SUM(V,1)/100;
阳倍:VOL>=REF(V,1)*1.87 AND C>REF(C,1) AND NOYZ,COLORRED,NODRAW;
STICKLINE(阳倍,0,V,-1,0),COLORRED;
阴倍:VOL>REF(V,1)*1.87 AND C<REF(C,1)  AND NOYZ,COLOR993333,NODRAW;
STICKLINE(阴倍,0,V,-1,0),COLOR993333;  
假阳:AMOUNT/V/100<REF(C,1) AND C>O AND C<300  AND NOYZ,COLOR76CC64,NODRAW;
STICKLINE(假阳,0,V,-1,0),COLOR76CC64;
假阴:(均价>REF(C,1) AND C<=O AND NOYZ) OR (C>REF(C,1) AND C<O AND NOYZ),NODRAW;
STICKLINE(假阴,0,V,-1,0),COLORFF1BB7;
查看全部打赏
  • 紫外线r+10理想币 : 感谢交流,感恩互助,收获知识能量!

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

紫外线r
Lv.2
发表于 2021-4-8 16:20 复制 查看全部楼层
要是哪位网友用了这个量柱可以加上两条量均线后,麻烦分享出来,大家都可以借鉴下午哈

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

紫外线r
Lv.2
发表于 2021-4-8 14:08 复制 查看全部楼层
本帖最后由 紫外线r 于 2021-4-8 14:10 编辑

这个是量柱源码:

成交额:AMO/100000000,COLORRED,NODRAW;
量:VOL,VOLSTICK;
换手: VOL*100/CAPITAL,NODRAW;
几倍: V/REF(V,1),COLORMAGENTA,NODRAW;
流通市值: FINANCE(40)/100000000,NODRAW;

{标记特殊成交量}
NOYZ:=NOT(C/REF(C,1)>1.095 AND H=O AND L=H);
均价:SUM(AMOUNT,1)/SUM(V,1)/100;
阳倍:VOL>=REF(V,1)*1.87 AND C>REF(C,1) AND NOYZ,COLORRED,NODRAW;
STICKLINE(阳倍,0,V,-1,0),COLORRED;
阴倍:VOL>REF(V,1)*1.87 AND C<REF(C,1)  AND NOYZ,COLOR993333,NODRAW;
STICKLINE(阴倍,0,V,-1,0),COLOR993333;  
假阳:AMOUNT/V/100<REF(C,1) AND C>O AND C<300  AND NOYZ,COLOR76CC64,NODRAW;
STICKLINE(假阳,0,V,-1,0),COLOR76CC64;
假阴:(均价>REF(C,1) AND C<=O AND NOYZ) OR (C>REF(C,1) AND C<O AND NOYZ),NODRAW;
STICKLINE(假阴,0,V,-1,0),COLORFF1BB7;

翻译

输出成交额:成交额(元)/100000000,画红色,NODRAW
输出量:成交量(手),VOLSTICK
输出换手: 成交量(手)*100/当前流通股本(手),NODRAW
输出 几倍: 成交量(手)/1日前的成交量(手),画洋红色,NODRAW
输出流通市值: 流通市值/100000000,NODRAW
NOYZ赋值:取反
输出 均价:成交额(元)的1日累和/成交量(手)的1日累和/100
输出阳倍:成交量(手)>=1日前的成交量(手)*1.87 AND 收盘价>1日前的收盘价 AND NOYZ,画红色,NODRAW
当满足条件阳倍时,在0和成交量(手)位置之间画柱状线,宽度为-1,0不为0则画空心柱.,画红色
输出阴倍:成交量(手)>1日前的成交量(手)*1.87 AND 收盘价<1日前的收盘价  AND NOYZ,COLOR993333,NODRAW
当满足条件阴倍时,在0和成交量(手)位置之间画柱状线,宽度为-1,0不为0则画空心柱.,COLOR993333
输出  假阳:成交额(元)/成交量(手)/100<1日前的收盘价 AND 收阳线AND 收盘价<300  AND NOYZ,COLOR76CC64,NODRAW
当满足条件假阳时,在0和成交量(手)位置之间画柱状线,宽度为-1,0不为0则画空心柱.,COLOR76CC64
输出假阴:(均价>1日前的收盘价 AND 收盘价<=开盘价 AND NOYZ) OR (收盘价>1日前的收盘价 AND 收阴线AND NOYZ),NODRAW
当满足条件假阴时,在0和成交量(手)位置之间画柱状线,宽度为-1,0不为0则画空心柱.,COLORFF1BB7

举报

使用道具 扔鸡蛋(0) 回复

紫外线r
Lv.2
发表于 2021-4-8 14:03 复制 查看全部楼层
风之风。 发表于 2021-4-8 13:29
MAVOL1:MA(VOLUME,5);
MAVOL2:MA(VOLUME,10);

先谢谢亲的热心解答,但是我添加后还是显示错误,我把图发上来帮看看到底是啥原因呢,愁死了






附件

QQ图片20210408141347.jpg

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

神九5410
Lv.2
发表于 2021-4-8 13:36 复制 查看全部楼层
谢谢楼主分享

举报

使用道具 扔鸡蛋(0) 回复

风之风。
Lv.6
发表于 2021-4-8 13:29 复制 查看全部楼层
MAVOL1:MA(VOLUME,5);
MAVOL2:MA(VOLUME,10);

举报

使用道具 点亮(1) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表