请老师帮助修改以下公式(通达信无法通过)

[通达信]
设置
1218 3 景逸863 Lv.4 发表于 · 2021-4-8 23:14 显示全部楼层 正序浏览 |
跳转到指定楼层

主力成本线主图


参数1: KET, 最小: 1, 最大: 100, 缺省: 10
参数2: HDAY, 最小: 2, 最大: 200, 缺省: 60

XA_1:=CLOSE;
BIX:(MA(XA_1,3)+MA(XA_1,6)+MA(XA_1,12)+MA(XA_1,24))/4,LINETHICK2;
EX12:EMA(CLOSE,20),LINETHICK2;
K20:MA(CLOSE,20),LINETHICK2;
K60:MA(CLOSE,60);
K250:MA(CLOSE,250);
EX50:EMA(CLOSE,60),COLORCYAN;
HIGH;
BIX;
EX12;
K20;
EX50;
K60;
XA_2:=(null);
LOW;
BIX;
EX12;
K20;
EX50;
K60;
XA_3:=(null);
XA_4:=IF(CLOSE>=SAR(4,2,20),SAR(4,2,20),0);
XA_5:=IF(CLOSE<SAR(4,2,20),SAR(4,2,20),0);
预区:IF(BIX>K20 AND EX12>BIX AND XA_4=0 AND XA_5>0,1,0),NODRAW;
直:IF(XA_4>0,REF(XA_5,BARSLAST(XA_5>0)),DRAWNULL),COLORWHITE,LINETHICK2;
XA_6:=HIGH=HHV(HIGH,500);
XA_7:=BARSLAST(XA_6);
XA_8:=BARSSINCEN(CROSS(MACD.DIF,MACD.DEA),XA_7);
XA_9:=HHV(HIGH,XA_7-20);
XA_10:=波段操作;
XA_11:=HHVBARS(HIGH,0);
XA_12:=IF(XA_11<3,3,XA_11);
XA_13:=HHVBARS(XA_10,XA_12);
XA_14:=REF(HIGH,XA_13);
过量标1:IF(Func_0x7579.SubValue_0x1>XA_14,1,0),NODRAW;
TST1:IF((XA_14-REF(CLOSE,1))/XA_14<0.3,XA_14,DRAWNULL),COLORBROWN,LINETHICK2;
XA_15:=HHVBARS(XA_10,0);
MOOP2:REF(HIGH,XA_15),NODRAW,COLORRED,LINETHICK2;
TST2:IF((MOOP2-REF(CLOSE,1))/MOOP2<0.3,MOOP2,DRAWNULL),COLORRED,LINETHICK2;
过量标2:IF(Func_0x7579.SubValue_0x1>MOOP2,1,0),NODRAW;
高开:IF(OPEN>REF(CLOSE,1),1,0),NODRAW;
红K:IF(CLOSE>OPEN,1,0),NODRAW;
HHD:(HHV(HIGH,0)-HHV(HIGH,HDAY))/HHV(HIGH,0),NODRAW,COLORYELLOW;
XA_16:=HIGH;
K坑:IF(XA_16<BIX AND XA_16<EX12 AND XA_16<K20,1,0),NODRAW;
XA_17:=波段操作;
XA_18:=波段操作;
XA_19:=波段操作;
XA_20:=波段操作;
XA_21:=波段操作;
V坑:IF(XA_17<XA_18 AND XA_17<XA_19 AND XA_17<XA_19 AND XA_17<XA_21,1,0),NODRAW;
K跳上:IF(LOW>REF(HIGH,1),1,0),NODRAW;
K跳下:IF(HIGH<REF(LOW,1),1,0),NODRAW;
上缺天数:BARSLAST(K跳上>0),NODRAW;
是上跳:IF(上缺天数<BARSLAST(K跳下>0),1,0),NODRAW;
K3预金:IF(EX12>BIX AND EX12>K20,1,0),NODRAW;
时内跳:IF(上缺天数<KET+1,1,0),NODRAW;
缺口值A:REF(HIGH,上缺天数+1),NODRAW;
缺口值B:LLV(LOW,上缺天数+1),NODRAW;
上缺未补X:IF(是上跳=1 AND 缺口值B>缺口值A,1,0),NODRAW;
K量跳:IF(COUNT(K坑,KET)>0 AND COUNT(V坑,KET)>0 AND CLOSE>BIX AND COUNT(是上跳,KET)>0 AND K3预金=1,1,0),NODRAW;
K量上:IF(COUNT(K坑,KET)>0 AND COUNT(V坑,KET)>0 AND CLOSE>BIX AND CLOSE>BIX,1,0),NODRAW;
K量跳日X:BARSLAST(K量跳>0),NODRAW;
K量上日:BARSLAST(K量上>0),NODRAW;
DRAWICON(K量跳>0,XA_3*0.96,3);
MK3跌:IF(K20<REF(K20,2) AND REF(K20,1)<REF(K20,3),1,0),NODRAW;
XA_22:=LLV(LOW,5);
XA_23:=REF(XA_22,4);
XA_24:=IF(XA_22<XA_23,1,0);
DRAWTEXT_FIX(ISLASTBAR,0.03,0.01,0,1),COLORLIRED;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.01,0,HYBLOCK);
DRAWNUMBER_FIX(ISLASTBAR,0.11,0.09,0,INTPART(DRAWTEXT_FIX(ISLASTBAR,0.03,0.09,0,2),COLORLIRED));
DRAWTEXT_FIX(ISLASTBAR,0.03,0.17,0,3),COLORLIRED;
DRAWTEXT_FIX(ISLASTBAR,0.11,0.17,0,GNBLOCK);
DRAWNUMBER_FIX(ISLASTBAR,0.38,0.01,0,INTPART(DRAWTEXT_FIX(ISLASTBAR,0.28,0.01,0,4),COLORLIRED));
DRAWTEXT_FIX(ISLASTBAR,0.28,0.09,0,5),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.38,0.09,0,FINANCE(45));
DRAWNUMBER_FIX(ISLASTBAR,0.62,0.01,0,INTPART(DRAWTEXT_FIX(ISLASTBAR,0.53,0.01,0,6),COLORLIRED));
DRAWNUMBER_FIX(ISLASTBAR,0.62,0.09,0,INTPART(DRAWTEXT_FIX(ISLASTBAR,0.53,0.09,0,7),COLORLIRED));
DRAWTEXT_FIX(ISLASTBAR,0.7,0.01,0,8),COLORLIRED;
DRAWTEXT_FIX(ISLASTBAR,0.81,0.01,0,DYBLOCK);

举报

使用道具 扔鸡蛋(0) 回复

景逸863
Lv.4
发表于 2021-4-9 15:31 复制 查看全部楼层
谢谢ainin 老师!

举报

使用道具 扔鸡蛋(0) 回复

ainin
Lv.5
发表于 2021-4-9 07:09 复制 查看全部楼层

举报

使用道具 扔鸡蛋(0) 回复

韭黄
Lv.2
发表于 2021-4-8 23:37 复制 查看全部楼层
这个指标有问题,中间的这些“BIX;
EX12;
K20;
EX50;
K60;
XA_2:=(null);
LOW;
BIX;
EX12;
K20;
EX50;
K60;
XA_3:=(null);”全都没有赋值,最后无法参与计算,要么就是你少了什么,要么就是这指标只发出来了一半。

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表