请老师帮忙合并一个选股

[通达信]
设置
1427 1 狼要吃肉 Lv.3 发表于 · 2021-4-14 01:38 显示全部楼层 正序浏览 |
跳转到指定楼层
选股一
涨停:=C/REF(C,1)>1.095;
涨停10日:=COUNT(涨停,10);
涨幅:=C/REF(C,1)-1<0.05;
选股1:=涨停10日 AND 涨幅 ;
BS:=COUNT(涨停,10)<2;
M10:=MA(C,7);
M20:=MA(C,14);
M30:=MA(C,25);
VV:=M10>M20 AND M20>M30 ;
S1:=IF(NAMELIKE('S'),0,1);
S2:=IF(NAMELIKE('*'),0,1);
回踩均线:=C>MA(C,7) AND CROSS(MA(C,7),L);
S3:=DYNAINFO(17)>0;
XG:S1 AND S2 AND S3 AND 选股1 AND 回踩均线 AND VV ;


选股二
CD1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(L,9))-0.7;
CD2:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9));
CD3:=SMA(SMA(CD2,3,1),3,1);
CD4:=(CD3-SMA(CD1,9,1))-0.5;
CD5:=IF(CD4>0.00,CD4,0.00);
CD6:=REF(CD5,1);
XG1:CROSS(CD6,CD5);

举报

使用道具 扔鸡蛋(0) 回复

注册111
Lv.6
发表于 2021-4-14 06:35 复制 查看全部楼层
涨停:=C/REF(C,1)>1.095;
涨停10日:=COUNT(涨停,10);
涨幅:=C/REF(C,1)-1<0.05;
选股1:=涨停10日 AND 涨幅 ;
BS:=COUNT(涨停,10)<2;
M10:=MA(C,7);
M20:=MA(C,14);
M30:=MA(C,25);
VV:=M10>M20 AND M20>M30 ;
S1:=IF(NAMELIKE('S'),0,1);
S2:=IF(NAMELIKE('*'),0,1);
回踩均线:=C>MA(C,7) AND CROSS(MA(C,7),L);
S3:=DYNAINFO(17)>0;
XG:=S1 AND S2 AND S3 AND 选股1 AND 回踩均线 AND VV ;

CD1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(L,9))-0.7;
CD2:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9));
CD3:=SMA(SMA(CD2,3,1),3,1);
CD4:=(CD3-SMA(CD1,9,1))-0.5;
CD5:=IF(CD4>0.00,CD4,0.00);
CD6:=REF(CD5,1);
XG1:=CROSS(CD6,CD5);
XG&&XG1;

举报

使用道具 点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /6 下一条
回顶部 到页底
快速回复 返回顶部 返回列表