手机版 理想小程序
理想小程序
RSS 论坛APP
返回列表

请冷妞妞老师帮忙修改完善通达信用的涨停板选股公式

[通达信] 9988 1
设置
3929234 Lv.4

专栏

复制 显示全部楼层 倒序浏览 |
跳转到指定楼层

股票公式,股票指标,股票,股票论坛,股票软件,通达信,涨停板选股公式,ST股威客任务_悬赏互助答疑专区股票软件指标公式技术理想股票技术论坛

下面是7个通达信选股公式,分别为一板~七连板及以上涨停板选股公式源码,但是这些公式都存在一个缺陷,即:不能选出当天和某时间段的ST股(含带星的ST股)! 请 ...威客任务_悬赏互助答疑专区股票软件指标公式技术

任务编号:9648912 指定威客20金钻 指定威客任务 : 甲方指定由 冷妞妞 进行任务。

请冷妞妞老师帮忙修改完善通达信用的涨停板选股公式

距截止: 任务已圆满完成 甲方已托管赏金:20 金钻
甲方发布需求21.05.13 甲方托管佣金21.05.13 威客投稿21.05.14 甲方开始选稿21.05.14 任务完成21.05.19

任务大厅共需1个合格投稿 | 每稿将获得20 金钻 | 交稿后不可编辑,被拒稿后才可再次交稿。

投诉举报 联系Ta 我来承接 已有1 个投稿 | 已采纳1 稿 | 拒绝0 稿 | 目前中标名额已满

任务需求:
    下面是7个通达信选股公式,分别为一板~七连板及以上涨停板选股公式源码,但是这些公式都存在一个缺陷,即:不能选出当天和某时间段的ST股(含带星的ST股)!
    请冷妞妞老师帮忙修改完善7个选股公式,使每个公式能通过通达信选出当天和某时间段符合一板、二连板、三连板、......、七连板及以上条件的沪深市所有涨停板,包括ST股(含带星的ST股)!

1.一板涨停选股指标源码:
X_1:=IF(NAMELIKE(1999),0,1);
X_2:=IF(NAMELIKE(2000),0,1);
X_3:=X_1 AND X_2;
X_4:=1201015;
X_5:=IF(0<1210130,1,0);
X_6:=IF(INBLOCK(145),0.2,IF(INBLOCK(146) AND 0>X_4,0.2,IF(INBLOCK(147),0.05,0.1)));
X_7:=CLOSE>=ZTPRICE(REF(CLOSE,1),X_6) AND CLOSE=HIGH;
XG:EVERY(X_7,1)*X_5 AND COUNT(X_7,2)=1 AND X_3 AND BARSCOUNT(CLOSE)>20 AND DYNAINFO(4)>0;

2.二连板涨停选股指标源码:
X_1:=IF(NAMELIKE(1999),0,1);
X_2:=IF(NAMELIKE(2000),0,1);
X_3:=X_1 AND X_2;
X_4:=1201015;
X_5:=IF(0<1210130,1,0);
X_6:=IF(INBLOCK(145),0.2,IF(INBLOCK(146) AND 0>X_4,0.2,IF(INBLOCK(147),0.05,0.1)));
X_7:=CLOSE>=ZTPRICE(REF(CLOSE,1),X_6) AND CLOSE=HIGH;
XG:EVERY(X_7,2)*X_5 AND COUNT(X_7,3)=2 AND X_3 AND BARSCOUNT(CLOSE)>15 AND DYNAINFO(4)>0;

3.三连板涨停选股指标源码:
X_1:=IF(NAMELIKE(1999),0,1);
X_2:=IF(NAMELIKE(2000),0,1);
X_3:=X_1 AND X_2;
X_4:=1201015;
X_5:=IF(0<1210130,1,0);
X_6:=IF(INBLOCK(145),0.2,IF(INBLOCK(146) AND 0>X_4,0.2,IF(INBLOCK(147),0.05,0.1)));
X_7:=CLOSE>=ZTPRICE(REF(CLOSE,1),X_6) AND CLOSE=HIGH;
XG:EVERY(X_7,3)*X_5 AND COUNT(X_7,4)=3 AND X_3 AND BARSCOUNT(CLOSE)>15 AND DYNAINFO(4)>0;

4.四连板涨停选股指标源码:
X_1:=IF(NAMELIKE(1999),0,1);
X_2:=IF(NAMELIKE(2000),0,1);
X_3:=X_1 AND X_2;
X_4:=1201015;
X_5:=IF(0<1210130,1,0);
X_6:=IF(INBLOCK(145),0.2,IF(INBLOCK(146) AND 0>X_4,0.2,IF(INBLOCK(147),0.05,0.1)));
X_7:=CLOSE>=ZTPRICE(REF(CLOSE,1),X_6) AND CLOSE=HIGH;
XG:EVERY(X_7,4)*X_5 AND COUNT(X_7,5)=4 AND X_3 AND BARSCOUNT(CLOSE)>20 AND DYNAINFO(4)>0;

5.五连板涨停选股指标源码:
X_1:=IF(NAMELIKE(1999),0,1);
X_2:=IF(NAMELIKE(2000),0,1);
X_3:=X_1 AND X_2;
X_4:=1201015;
X_5:=IF(0<1210130,1,0);
X_6:=IF(INBLOCK(145),0.2,IF(INBLOCK(146) AND 0>X_4,0.2,IF(INBLOCK(147),0.05,0.1)));
X_7:=CLOSE>=ZTPRICE(REF(CLOSE,1),X_6) AND CLOSE=HIGH;
XG:EVERY(X_7,5)*X_5 AND COUNT(X_7,6)=5 AND X_3 AND BARSCOUNT(CLOSE)>20 AND DYNAINFO(4)>0;

6.六连板涨停选股指标源码:
X_1:=IF(NAMELIKE(1999),0,1);
X_2:=IF(NAMELIKE(2000),0,1);
X_3:=X_1 AND X_2;
X_4:=1201015;
X_5:=IF(0<1210130,1,0);
X_6:=IF(INBLOCK(145),0.2,IF(INBLOCK(146) AND 0>X_4,0.2,IF(INBLOCK(147),0.05,0.1)));
X_7:=CLOSE>=ZTPRICE(REF(CLOSE,1),X_6) AND CLOSE=HIGH;
XG:EVERY(X_7,6)*X_5 AND COUNT(X_7,7)=6 AND X_3 AND BARSCOUNT(CLOSE)>20 AND DYNAINFO(4)>0;

7.七连板及以上涨停选股指标源码:
X_1:=IF(NAMELIKE(1999),0,1);
X_2:=IF(NAMELIKE(2000),0,1);
X_3:=X_1 AND X_2;
X_4:=1201015;
X_5:=IF(0<1210130,1,0);
X_6:=IF(INBLOCK(145),0.2,IF(INBLOCK(146) AND 0>X_4,0.2,IF(INBLOCK(147),0.05,0.1)));
X_7:=CLOSE>=ZTPRICE(REF(CLOSE,1),X_6) AND CLOSE=HIGH;
XG:EVERY(X_7,7)*X_5 AND COUNT(X_7,8)=7 AND X_3 AND BARSCOUNT(CLOSE)>20 AND DYNAINFO(4)>0;
任务需求补充 补充于2021-5-14 00:02
冷妞妞老师,忘了提一点,我是将这7个涨停板选股公式作盘后复盘用,不需要盘中选。
939.middle
2670939
Lv.7

专栏

发表于 2021-5-14 15:38 复制 查看全部楼层 屏蔽
已采纳
您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
131943xjzjpcd6s1hvja2p
160828rrwbe8b2ijeeae8w
站长推荐 /1

最新主题

回顶部 到页底