请老师帮助做个选股公式

[通达信] 2152 2
设置
3908405 Lv.3

专栏

发表于 2021-5-19 20:52 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
请高手做个选股,只有一个条件,选出当天“上和下两条轨道都是红色的”股票。谢谢!

DRAWGBK(C>O,RGB(10,0,0),RGB(0,0,0),1,2,1);
DRAWKLINE(H,O,L,C);
安全:=MA(C,30),CIRCLEDOT,COLORFF00FF;
当日成本:=IF(C>REF(C,1),(3*H+4*C+3*OPEN+2*L)/12,(2*H+4*C+3*OPEN+3*L)/12);
龙头线:EXPMEMA(当日成本,13),LINETHICK2,COLORMAGENTA;
慢牛线:=EXPMEMA(当日成本,51),LINETHICK2,COLORMAGENTA;
IF(龙头线<=REF(龙头线,2),龙头线,DRAWNULL),COLORGREEN,LINETHICK2;
波段高:(XMA(XMA(HIGH,30),30)-XMA(XMA(LOW,30),30))*2+XMA(XMA(HIGH,30),30),COLORWHITE,LINETHICK1;

波段低:XMA(XMA(LOW,30),30)-(XMA(XMA(HIGH,30),30)-XMA(XMA(LOW,30),30))*1.5,COLORWHITE,LINETHICK1;

俞言友情:(波段高+波段低)/2,DOTLINE,COLOR909090;

IF(波段高>=REF(波段高,1),波段高,DRAWNULL),COLORRED,LINETHICK2;

IF(波段低>=REF(波段低,1),波段低,DRAWNULL),COLORRED,LINETHICK2;

IF(波段高<=REF(波段高,1),波段高,DRAWNULL),COLOR008800,LINETHICK3;

IF(波段低<=REF(波段低,1),波段低,DRAWNULL),COLOR008800,LINETHICK3;

STICKLINE(REF(LOW,1)<波段低 AND CLOSE>波段低 AND 波段高>=REF(波段高,1) AND CLOSE>OPEN,CLOSE,OPEN,(-1),0),COLORYELLOW;

STICKLINE(REF(HIGH,1)>=波段高 AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN,CLOSE,OPEN,(-1),0),COLORFF6600;

DRAWTEXT_FIX(ISLASTBAR,0,0,0,FGBLOCK);

DRAWTEXT_FIX(ISLASTBAR,0,0.1,0,GNBLOCK);

DRAWICON(REF(LOW,1)<波段低 AND CLOSE>波段低 AND 波段高>=REF(波段高,1) AND CLOSE>OPEN,LOW,5);

DRAWICON(REF(HIGH,1)>=波段高 AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN,HIGH,6);


BK:=IF(INBLOCK('科创板'),0.2,IF(INBLOCK('ST板块'),0.05,0.1));
XA_1:=IF(DATE<=1200823,1,0);
STICKLINE((C=ZTPRICE(REF(CLOSE,1),0.1) AND C=H) AND XA_1=1,O,C,2.7,0),COLORFF00FF;
STICKLINE((C=DTPRICE(REF(CLOSE,1),0.1) AND C=L) AND XA_1=1,O,C,2.7,0),COLOR80FF00;
STICKLINE((C>=ZTPRICE(REF(C,1),BK) AND C=H),C,O,2.7,0),COLORFF00FF;
STICKLINE((C<=DTPRICE(REF(C,1),BK) AND C=L),C,O,2.7,0),COLOR80FF00;
实三一:O+(C-O)*2/3,NODRAW;
实三二:O+(C-O)/3,NODRAW;
实二一:(O+C)*0.5,NODRAW;
STICKLINE(实二一,实二一,实二一,2,0),COLORBLUE;
{跳空高开画蓝色}
TK:=C>O AND O>=REF(MAX(C,O),1)+0.01 OR O>=REF(C,1)+0.01 ;
STICKLINE(TK, O,(C-O)*0.01+O,4,0),COLORYELLOW;

AAA:=(3*C+H+L+O)/6;
VAR1AA:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)
+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
波段线:=VAR1AA,COLORWHITE,LINETHICK1;


X_A1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
逃命顶:=X_A1>20 AND FILTER(X_A1<REF(X_A1,1),5),COLORYELLOW;
DRAWTEXT(FILTER(逃命顶,3),MAX(C,O),'逃命顶')COLORCYAN;



来自 北京市

举报

使用道具 扔鸡蛋 回复

3908405
Lv.3

专栏

发表于 2021-5-19 21:30 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 北京市

举报

使用道具 支持 扔鸡蛋 回复

3635083
Lv.6

专栏

发表于 2021-5-19 21:08 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
  • 福阿德+6理想币 +4共享币 : 感谢知识分享,感谢经验交流。
查看全部打赏
来自 山东省青岛市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表