请老师帮忙编写个选股公式

[通达信]
设置
2289 10 睡觉天天 Lv.2 发表于 · 2021-6-20 01:12 显示全部楼层 正序浏览 |
跳转到指定楼层
我有a.b.c.d.e.5个信号发出条件      

想要其中一个条件或多个条件发出信号后  
第二天  另外4个条件的其中1个条件或1个以上也发出信号   
同一只股票发出信号后  5天内不再重复发出第二次信号
然后选出股票

但是必须所有信号都要有a参与    不管a信号在前面还是后面


谢谢老师

举报

使用道具 扔鸡蛋 回复

睡觉天天
Lv.2
发表于 2021-6-20 15:20 复制 查看全部楼层 屏蔽
一粒金丹 发表于 2021-6-20 01:55
{以统计阳线数量开始增多为信号,统计参数分别为5,6,7,8,9,
B-1.2.3.4.5分别对应A.B.C.D.E.}
A1:=CO ...

https://www.55188.com/thread-9687972-1-1.html

老师有空吗 这边的公式能帮我写下吗

举报

使用道具 点亮 支持 扔鸡蛋 回复

一粒金丹
Lv.2
发表于 2021-6-20 03:29 复制 查看全部楼层 屏蔽

举报

使用道具 支持 扔鸡蛋 回复

一粒金丹
Lv.2
发表于 2021-6-20 03:28 复制 查看全部楼层 屏蔽
{这里打几个字,要么不让发}
A1:=COUNT(C>O,5);
A2:=COUNT(C>O,6);
A3:=COUNT(C>O,7);
A4:=COUNT(C>O,8);
A5:=COUNT(C>O,9);
B1:=A1>REF(A1,1)&&REF(A1<=REF(A1,1),1);
B2:=A2>REF(A2,1)&&REF(A2<=REF(A2,1),1);
B3:=A3>REF(A3,1)&&REF(A3<=REF(A3,1),1);
B4:=A4>REF(A4,1)&&REF(A4<=REF(A4,1),1);
B5:=A5>REF(A5,1)&&REF(A5<=REF(A5,1),1);
C1:=REF((B1+B2+B3+B4+B5)>1&&(B1+B2+B3+B4+B5)<5,1)&&(B1+B2+B3+B4+B5)>1&&B1||REF(B1,1);
C2:=REF(B1,1)&&(B2+B3+B4+B5)=1;
C3:FILTER(C2,5);{第二天余下的只有一个条件成立};
查看全部打赏
  • 睡觉天天+10理想币 : 感谢知识分享,感谢经验交流。

举报

使用道具 支持 扔鸡蛋 回复

睡觉天天
Lv.2
发表于 2021-6-20 03:08 复制 查看全部楼层 屏蔽
前一天a发出信号   然后第二天bcde  其中一个发出信号        选出股票

举报

使用道具 点亮 支持 扔鸡蛋 回复

睡觉天天
Lv.2
发表于 2021-6-20 03:05 复制 查看全部楼层 屏蔽
本帖最后由 睡觉天天 于 2021-6-20 03:09 编辑
一粒金丹 发表于 2021-6-20 02:59
{哎。。。提示我不要重复发复制内容}
A1:=COUNT(C>O,5);
A2:=COUNT(C>O,6);


111.png


老师现在变成了这样



前一天a发出信号   然后第二天bcde  其中一个发出信号        选出股票

老师这样会更容易编写吗

举报

使用道具 点亮 支持 扔鸡蛋 回复

一粒金丹
Lv.2
发表于 2021-6-20 02:59 复制 查看全部楼层 屏蔽
{哎。。。提示我不要重复发复制内容}
A1:=COUNT(C>O,5);
A2:=COUNT(C>O,6);
A3:=COUNT(C>O,7);
A4:=COUNT(C>O,8);
A5:=COUNT(C>O,9);
B1:=A1>REF(A1,1)&&REF(A1<=REF(A1,1),1);
B2:=A2>REF(A2,1)&&REF(A2<=REF(A2,1),1);
B3:=A3>REF(A3,1)&&REF(A3<=REF(A3,1),1);
B4:=A4>REF(A4,1)&&REF(A4<=REF(A4,1),1);
B5:=A5>REF(A5,1)&&REF(A5<=REF(A5,1),1);
C1:=REF((B1+B2+B3+B4+B5)>1&&(B1+B2+B3+B4+B5)<5,1)&&(B1+B2+B3+B4+B5)>1&&B1||REF(B1,1);
C2:=(B1+B2+B3+B4+B5)=1&&B1;
C3:FILTER(C1||C2,5);
{改成了当天A发出信号,似乎没有问题};


举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

睡觉天天
Lv.2
发表于 2021-6-20 02:47 复制 查看全部楼层 屏蔽
一粒金丹 发表于 2021-6-20 02:29
A1:=COUNT(C>O,5);
A2:=COUNT(C>O,6);
A3:=COUNT(C>O,7);


20210620024708.png

还是跟上面那个一样 能再看看吗

最下面倒数第2个信号

举报

使用道具 点亮 支持 扔鸡蛋 回复

一粒金丹
Lv.2
发表于 2021-6-20 02:29 复制 查看全部楼层 屏蔽
A1:=COUNT(C>O,5);
A2:=COUNT(C>O,6);
A3:=COUNT(C>O,7);
A4:=COUNT(C>O,8);
A5:=COUNT(C>O,9);
B1:=A1>REF(A1,1)&&REF(A1<=REF(A1,1),1);
B2:=A2>REF(A2,1)&&REF(A2<=REF(A2,1),1);
B3:=A3>REF(A3,1)&&REF(A3<=REF(A3,1),1);
B4:=A4>REF(A4,1)&&REF(A4<=REF(A4,1),1);
B5:=A5>REF(A5,1)&&REF(A5<=REF(A5,1),1);
C1:=REF((B1+B2+B3+B4+B5)>1&&(B1+B2+B3+B4+B5)<5,1)&&(B1+B2+B3+B4+B5)>1&&B1||REF(B1,1);
C2:=REF((B1+B2+B3+B4+B5)=1&&B1,1);
C3:FILTER(C1||C2,5);
{加了一个昨天只有A发出信号,不是当天A发出信号,可以改,不矛盾,看看有没有问题};

举报

使用道具 支持 扔鸡蛋 回复

睡觉天天
Lv.2
发表于 2021-6-20 02:12 复制 查看全部楼层 屏蔽
20210620020958.png

老师第一个就是a


但是只有第一个有信号    另外4个没有发出信号的时候    新公式也发出信号   能帮忙修改下吗

举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

一粒金丹
Lv.2
发表于 2021-6-20 01:55 复制 查看全部楼层 屏蔽
{以统计阳线数量开始增多为信号,统计参数分别为5,6,7,8,9,
B-1.2.3.4.5分别对应A.B.C.D.E.}
A1:=COUNT(C>O,5);
A2:=COUNT(C>O,6);
A3:=COUNT(C>O,7);
A4:=COUNT(C>O,8);
A5:=COUNT(C>O,9);
B1:=A1>REF(A1,1)&&REF(A1<=REF(A1,1),1);
B2:=A2>REF(A2,1)&&REF(A2<=REF(A2,1),1);
B3:=A3>REF(A3,1)&&REF(A3<=REF(A3,1),1);
B4:=A4>REF(A4,1)&&REF(A4<=REF(A4,1),1);
B5:=A5>REF(A5,1)&&REF(A5<=REF(A5,1),1);
XG:FILTER(REF((B1+B2+B3+B4+B5)>1&&(B1+B2+B3+B4+B5)<5,1)&&(B1+B2+B3+B4+B5)>1&&B1||REF(B1,1),5);
{应该没有问题}

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /6 下一条
回顶部 到页底
快速回复 返回顶部 返回列表