请老师帮助将此改为选股公式(条件如下)

[通达信]
设置
2857 1 钱误股人 Lv.3 发表于 · 2021-7-25 01:01 显示全部楼层 正序浏览 |
跳转到指定楼层
N:=24;
A1:=DATE <= 1070615;
A2:=(100*(CLOSE-(MA(CLOSE,30))))/(MA(CLOSE,30));
A3:=100-((90*((HHV(HIGH,20))- CLOSE))/((HHV(HIGH,20))-(LLV(LOW,20))));
A4:=100-(MA(((100*((HHV(HIGH,6))-CLOSE))/((HHV(HIGH,6))-(LLV(LOW,6)))),28));
A5:=MA(A4,6);
L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
L2:=EMA(L1,9);
L3:=BARSLAST(CROSS(L1,L2));
L4:=REF(L3,L3+1);
L5:=L2;
红持股:IF((A3 < A5),A5,A3),COLORRED;
绿持币:IF((A3 > A5),A5,A3),COLORGREEN;
强弱:(A5),LINETHICK1,COLORYELLOW;
变盘:CROSS(L1,L2) AND L5,NODRAW,COLORD6FF9C;
STICKLINE(变盘,5,0,0,1),COLORD6FF9C;
DIFF:(EMA(CLOSE,12) - EMA(CLOSE,26))*20,COLORWHITE,LINETHICK1;
DEA:EMA(DIFF,9),COLORYELLOW,LINETHICK1;
MACD:2*(DIFF-DEA),COLORSTICK;
MACD1:=2*(DIFF-DEA),COLORRED,NODRAW;
MACD2:=EMA(MACD1,3),COLORCYAN,NODRAW;
A14:=EMA(CLOSE,8);
A15:=EMA(A14,20);
A16:=CROSS(A14,A15);
A17:=A14 < (EMA(CLOSE,120));
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLORYELLOW;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORGREEN;
LS:=IF(DIFF>DEA AND DIFF>0,1,0);
加速上扬:IF(REF(LS=0,1) AND LS=1,0.1,0);
大波黑马起步:((A16 AND A17) * 75) * A1,LINETHICK2,COLORMAGENTA;
XG1:CROSS(MACD1,MACD2) AND MACD1<0,NODRAW;
XG2:CROSS(DIFF,DEA),NODRAW;
M1:=MACD>REF(MACD,1) AND DIFF<DEA;
绿柱短了:M1 AND COUNT(M1,10)=1 AND C>MA(C,55) AND COUNT(MACD<0,5)>=5,NODRAW;
DRAWTEXT(绿柱短了,MACD,'买点来了');
A18:=SUM((IF((CLOSE > (REF(CLOSE,1))),VOL,(IF((CLOSE < (REF(CLOSE,1))),(0 - VOL),0)))),0);
A19:=SUMBARS(VOL,CAPITAL);
A20:=(IF((CLOSE > (LLV(CLOSE,A19))),1,-1)) * (IF((A18 > (LLV(A18,A19))),1,-1));
A21:=IF((A20 = -1),1,0);
DIFL:=EMA(V,12)-EMA(V,26);
DIF:=EMA(C,12)-EMA(C,26);
BL:=DIFL>REF(DIFL,1) AND DIF<REF(DIF,1);
A22:=(COUNT((A21 = 1),8)) > 2;
A23:=((SUM(AMOUNT,13)) / ((AMOUNT / VOL) / 100)) / 100;
A24:=DMA((((((3 * HIGH) + LOW) + OPEN) + (2 * CLOSE)) / 7),(VOL / A23));
A25:=(((CLOSE - A24) / A24) * 100) < -15;
四天: REF(BL,3)=1 AND REF(BL,2)=1 AND REF(BL,1)=1 AND BL;
三天:REF(BL,2)=1 AND REF(BL,1)=1 AND BL;
IF(DIFF>DEA,DIFF,DRAWNULL),COLORFF11CC,LINETHICK1;
IF(DIFF>DEA AND DIFF<0,DIFF,DRAWNULL),COLORRED,LINETHICK1;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
A26:=((CLOSE - (MIN(((REF(CLOSE,5)) * 0.865),((REF(CLOSE,21)) * 0.772)))) / CLOSE) < 0.05;
A27:=REF(LOW,1);
A28:=((SMA(ABS((LOW - A27)),3,1)) / (SMA((MAX((LOW - A27),0)),3,1))) * 100;
A29:=EMA((IF((CLOSE * 1.2),(A28 * 10),(A28 / 10))),3);
DRAWTEXT(FILTER(D>80,6),H*1.018,'D>80');
DRAWTEXT(FILTER(CROSS(K,D) AND D<26,6),H*0.95,'KD低位金叉'),COLORFFCCCC;
STICKLINE(FILTER(CROSS(K,D) AND D<26,6),H*0.97,H*0.95,4,0),COLORFFCCCC;
DIFFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
A30:=LLV(LOW,38);
A31:=HHV(A29,38);
DEAF :=EMA(DIFFF,9);
MACDD:=2*(DIFFF-DEAF);
A32:=IF((LLV(LOW,90)),1,0);
A33:=((EMA((IF((LOW <= A30),((A29 + (A31 * 2)) / 2),0)),3)) / 618) * A32;
ROC:=(CLOSE-REF(CLOSE,21))/REF(CLOSE,21)*100;
WWWAICHAGUCOM:= EMA(EMA(CLOSE,13),13);
DRAWTEXT(FILTER(CROSS(ROC,0),6),L-2.25,'骗线拐点'),COLORWHITE;
STICKLINE(FILTER(CROSS(ROC,0),6),L-0.02,L-0.15,5,0),COLORFF00FF;
庄家吸筹留踪影:(STICKLINE(A33,0,A33,6,1)) ,COLORWHITE;





条件: (绿持币>40 AND  <50) AND      红持股=100 AND 红持股(前一日>56 AND <86)

本帖寻求各位老师的解答

 正茂风华2021-7-25 05:31发表回复被钱误股人采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

举报

使用道具 扔鸡蛋 回复

正茂风华
Lv.3
发表于 2021-7-25 05:31 复制 查看全部楼层
N:=24;
A1:=DATE <= 1070615;
A2:=(100*(CLOSE-(MA(CLOSE,30))))/(MA(CLOSE,30));
A3:=100-((90*((HHV(HIGH,20))- CLOSE))/((HHV(HIGH,20))-(LLV(LOW,20))));
A4:=100-(MA(((100*((HHV(HIGH,6))-CLOSE))/((HHV(HIGH,6))-(LLV(LOW,6)))),28));
A5:=MA(A4,6);
L1:=(EMA(CLOSE,3) - EMA(CLOSE,13));
L2:=EMA(L1,9);
L3:=BARSLAST(CROSS(L1,L2));
L4:=REF(L3,L3+1);
L5:=L2;
红持股:=IF((A3 < A5),A5,A3),COLORRED;
绿持币:=IF((A3 > A5),A5,A3),COLORGREEN;
(绿持币>40 AND 绿持币 < 50) AND  ( 红持股=100 AND REF(红持股,1)>56 AND REF(红持股,1) <86);
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /6 下一条
回顶部 到页底
快速回复 返回顶部 返回列表