编写选股公式和副图

[通达信]
设置
6772 3 行云yjl Lv.3 发表于 · 2021-9-3 11:09 显示全部楼层 正序浏览 |
跳转到指定楼层
任务编号:9768669 悬赏任务10金钻 悬赏任务 : 按甲方需求进行任务后提交稿件,被采纳后即获得佣金。

编写选股公式和副图

距截止: 任务已圆满完成 甲方已托管赏金:10 金钻
甲方发布需求21.09.03 甲方托管佣金21.09.03 威客投稿21.09.03 甲方开始选稿21.09.06 任务完成21.09.15

任务大厅共需1个合格投稿 | 每稿将获得10 金钻 | 交稿后不可编辑,被拒稿后才可再次交稿。

投诉举报 联系Ta 我来承接 已有3 个投稿 | 已采纳0 稿 | 拒绝3 稿 | 还需要1 稿

任务需求:
下面是几条趋势线公式源码。希望这个N设置三个不同的值(不同数值取点不同,但有相同的),多条趋势线能够共同出现在一个页面(改写公式也可以),重复的只显示一条,原则上希望取点全面而已。副图:股价位于趋势线附近(0.98*股价,1.02*股价之间)标记绿箭头,任何两条趋势线相交标记红箭头。选股公式也是这两个条件选股。

需要用到C语言和排列组合概念。

N:=7;
A1:=REF(H,N)=HHV(H,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:FILTER(C1,N),NODRAW;{高点}
A2:=REF(L,N)=LLV(L,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:FILTER(C2,N),NODRAW;{低点}
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2;
E2:=(H+L)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2));  
H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1),LINETHICK0;{过滤后低点}
L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1;
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1),LINETHICK0;{过滤后高点}
R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1);
S1:R1>REF(R1,1),NODRAW; {前一高}
T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);
U1:=T1>REF(T1,1); {前一低}
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2);
S2:=R2>REF(R2,1); {前二高}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2);
U2:=T2>REF(T2,1); {前二低}
T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2);
U3:=T3>REF(T3,1); {前三低}
T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2);
U4:=T4>REF(T4,1); {前四低}
R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2);
S3:=R3>REF(R3,1); {前三高}
R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2);
S4:=R4>REF(R4,1); {前四高}
压力1:DRAWLINE(S2,H,S1,H,1),COLORMAGENTA,LINETHICK1;
支撑1:DRAWLINE(U2,L,U1,L,1),COLOR8FBC8F,LINETHICK1;
压力2:DRAWLINE(S3,H,S2,H,1),COLORFF8000;
支撑2:DRAWLINE(U3,L,U2,L,1),COLOR99CC32;         
压力3:DRAWLINE(S4,H,S3,H,1),COLOR0000FF;
支撑3:DRAWLINE(U4,L,U3,L,1),COLORWHITE;

{DRAWICON(S2,H*1.01,10);
DRAWICON(S3,H*1.01,10);}
DRAWNUMBER(S2,H*1.02,H),COLORCFB53B;
DRAWNUMBER(S1,H*1.02,H),COLORCFB53B;
DRAWNUMBER(S3,H*1.02,H),COLORCFB53B;
DRAWICON(U1,L*0.99,11);
{DRAWICON(U2,L*0.99,11);
DRAWICON(U3,L*0.99,11);
DRAWICON(U4,L*0.99,11);}
DRAWNUMBER(U1,L*0.98,L),COLORCYAN;
DRAWNUMBER(U2,L*0.98,L),COLORCYAN;
DRAWNUMBER(U3,L*0.98,L),COLORCYAN;
DRAWNUMBER(U4,L*0.98,L),COLORCYAN;
任务需求补充 补充于2021-9-3 12:36
箭头必须标记在两个取点之间的延长线上的交叉点,或者股价位于延长线附近(非常接近也可以),两点之间不要标记

举报

使用道具 扔鸡蛋 回复

妖股狙击
Lv.3
发表于 2021-9-4 14:28 复制 查看全部楼层 屏蔽
已拒绝
给他留言
该稿件已被甲方拒绝,理由是:
谢谢提醒

举报

使用道具 点亮 支持 扔鸡蛋 回复

响马
Lv.4
发表于 2021-9-3 12:50 复制 查看全部楼层 屏蔽
已拒绝
给他留言
该稿件已被甲方拒绝,理由是:
不符合要求
附件: 您需要 登录 才可以下载或查看,没有帐号?

举报

使用道具 点亮 支持 扔鸡蛋 回复

大卫1214
Lv.6
发表于 2021-9-3 11:24 复制 查看全部楼层 屏蔽
已拒绝
给他留言
该稿件已被甲方拒绝,理由是:
不符合要求
附件: 您需要 登录 才可以下载或查看,没有帐号?

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /6 下一条
回顶部 到页底
快速回复 返回顶部 返回列表