请老师帮我改有出现红柱妖股的选股公式

[通达信]
设置
3099 3 方祥2009 Lv.2 发表于 · 2021-9-10 07:35 显示全部楼层 正序浏览 |
跳转到指定楼层
HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
黄线:=(20*HHJSJDA+19*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
+7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
REF(HHJSJDA,20))/210;
绿线:=MA(黄线,5);
持股区域:=黄线>绿线 AND C>=黄线,COLORMAGENTA;
区域:=C>REF(H,1);

C>黄线*0.8 AND C<黄线*1.2;
M:=55;
N:=34;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(85,RSI),75,'▼'),COLORGREEN;
VAR1:=IF(YEAR>=2038 AND MONTH>=1,0,1);
VAR2:=REF(LOW,1)*VAR1;
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100*VAR1;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3)*VAR1;
VAR5:=LLV(LOW,30)*VAR1;
VAR6:=HHV(VAR4,30)*VAR1;
VAR7:=IF(MA(CLOSE,58),1,0)*VAR1;
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*VAR1;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
MA5:=MA(C,5),COLORF00FF0;
MA10:=MA(C,10),COLORE66878;
MA20:=MA(C,20),COLORYELLOW;
MA60:=MA(C,60),COLORGREEN;

吸筹:=IF(VAR8>100,100,VAR8)*VAR1,COLORRED;
庄家吸筹:STICKLINE(吸筹>-150,0,吸筹,3,0),COLORRED;
散户: 100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M)),COLORFFFF00,LINETHICK2;
庄家:EMA(J,6),COLORFF00FF,LINETHICK2;

庄低:=庄家<REF(庄家,1);
散低:=散户<=REF(散户,1);
庄底:=庄家>REF(庄家,1) AND REF(庄家,1)<REF(庄家,2);
庄顶:=庄家<REF(庄家,1) AND REF(庄家,1)>REF(庄家,2);
HH:=庄低 AND 散低 AND 区域 AND 持股区域;



伏:IF(HH,88,0),COLORRED,STICK,LINETHICK4;
DRAWICON(伏=88,77,29);
DRAWICON(伏=88,66,9);
DRAWICON(伏=88,44,25);
DRAWICON(伏=88,22,17);
DRAWICON(伏=88,11.3,17);
缩量:=REF(LLV(VOL,5),REF(MA10,1)) AND MA20>REF(MA20,1);
AA2:=MA10>REF(MA10,1) AND MA60>REF(MA60,1);

多头:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60);
向上:=MA5>REF(MA5,1);
涨幅:=C/REF(C,1)>=1.01;
有拐点:=REF(HHV(庄底,8)>0,0);
底拐点:=IF(庄底,10,0);
A1:=BARSLAST(底拐点>0);
A2:=IF(REF(庄家,A1+1)>=庄家 AND REF(C,A1+1)<=C,10,0);
A3:=IF(REF(庄家,A1+1)<=庄家 AND REF(C,A1+1)>=C,10,0);
A4:=IF(A2 OR A3,10,0);
顶拐点:=IF(庄顶,90,100);
多头向上:=IF(向上 AND 多头,40,0);
背离起爆:IF(庄底 AND REF(A4,1)>1 AND MA5>REF(MA5,1),30,0),COLORMAGENTA,LINETHICK2;
金叉:IF(CROSS(庄家,散户) AND 庄家>=REF(庄家,1),50,0),COLORYELLOW,LINETHICK2;


XA_1:=VOL;
XA_2:=XA_1>MA(VOL,89);
XA_3:=EXPMA(CLOSE,5);
XA_4:=EXPMA(CLOSE,29);
XA_5:=XA_3>XA_4;
XA_6:=REF(CLOSE,1);
XA_7:=SMA(MAX(CLOSE-XA_6,0),12,1)/SMA(ABS(CLOSE-XA_6),12,1)*100;
XA_8:=SMA(MAX(CLOSE-XA_6,0),56,1)/SMA(ABS(CLOSE-XA_6),56,1)*100;
XA_9:=XA_7>XA_8 AND XA_5 AND XA_2 AND DMI.ADX#WEEK(14)!=0;
XA_10:=HHV(HIGH,30);
XA_11:=LLV(LOW,30);
XA_12:=REF((XA_10/XA_11-1)*100<=30,1);
XA_13:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,23))/EMA(CLOSE,23));
XA_14:=DMA((2.15*CLOSE+LOW+HIGH)/4,XA_13);
XA_15:=EMA(XA_14,200)*1.1;
XA_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
妖股:CROSS(CLOSE,XA_15) AND REF(CLOSE*1.097,1)<CLOSE AND XA_9 AND XA_12,NODRAW;
STICKLINE(IF(妖股,120,0),50,0,3,0),COLORRED;
DRAWTEXT(妖股,50,'妖股'),COLORYELLOW;

本帖寻求各位老师的解答

 风之风。2021-9-10 07:52发表回复被方祥2009采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

举报

使用道具 扔鸡蛋 回复

经纬天下
Lv.2
发表于 2021-9-10 11:52 复制 查看全部楼层
好好好,感谢

举报

使用道具 支持 扔鸡蛋 回复

吴昊昊
Lv.2
发表于 2021-9-10 08:16 复制 查看全部楼层
HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
黄线:=(20*HHJSJDA+19*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
+7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
REF(HHJSJDA,20))/210;
绿线:=MA(黄线,5);
持股区域:=黄线>绿线 AND C>=黄线,COLORMAGENTA;
区域:=C>REF(H,1);


M:=55;
N:=34;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);

VAR1:=IF(YEAR>=2038 AND MONTH>=1,0,1);
VAR2:=REF(LOW,1)*VAR1;
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100*VAR1;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3)*VAR1;
VAR5:=LLV(LOW,30)*VAR1;
VAR6:=HHV(VAR4,30)*VAR1;
VAR7:=IF(MA(CLOSE,58),1,0)*VAR1;
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*VAR1;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
MA5:=MA(C,5),COLORF00FF0;
MA10:=MA(C,10),COLORE66878;
MA20:=MA(C,20),COLORYELLOW;
MA60:=MA(C,60),COLORGREEN;

吸筹:=IF(VAR8>100,100,VAR8)*VAR1,COLORRED;

散户:=100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M)),COLORFFFF00,LINETHICK2;
庄家:=EMA(J,6),COLORFF00FF,LINETHICK2;

庄低:=庄家<REF(庄家,1);
散低:=散户<=REF(散户,1);
庄底:=庄家>REF(庄家,1) AND REF(庄家,1)<REF(庄家,2);
庄顶:=庄家<REF(庄家,1) AND REF(庄家,1)>REF(庄家,2);
HH:庄低 AND 散低 AND 区域 AND 持股区域;




举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

风之风。
Lv.6
发表于 2021-9-10 07:52 复制 查看全部楼层
XA_1:=VOL;
XA_2:=XA_1>MA(VOL,89);
XA_3:=EXPMA(CLOSE,5);
XA_4:=EXPMA(CLOSE,29);
XA_5:=XA_3>XA_4;
XA_6:=REF(CLOSE,1);
XA_7:=SMA(MAX(CLOSE-XA_6,0),12,1)/SMA(ABS(CLOSE-XA_6),12,1)*100;
XA_8:=SMA(MAX(CLOSE-XA_6,0),56,1)/SMA(ABS(CLOSE-XA_6),56,1)*100;
XA_9:=XA_7>XA_8 AND XA_5 AND XA_2 AND DMI.ADX#WEEK(14)!=0;
XA_10:=HHV(HIGH,30);
XA_11:=LLV(LOW,30);
XA_12:=REF((XA_10/XA_11-1)*100<=30,1);
XA_13:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,23))/EMA(CLOSE,23));
XA_14:=DMA((2.15*CLOSE+LOW+HIGH)/4,XA_13);
XA_15:=EMA(XA_14,200)*1.1;
XA_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
妖股:CROSS(CLOSE,XA_15) AND REF(CLOSE*1.097,1)<CLOSE AND XA_9 AND XA_12;
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /6 下一条
回顶部 到页底
快速回复 返回顶部 返回列表