转化个选股公式

[通达信]
设置
4547 3 实施转 Lv.2 发表于 · 2021-9-16 17:16 显示全部楼层 正序浏览 |
跳转到指定楼层
求大神帮我改成选股公式

VARR1:=V;
VARR2:=VARR1>MA(V,89);
VARR3:=EXPMA(C,5);
VARR4:=EXPMA(C,29);
VARR5:=VARR3>VARR4;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),56,1)/SMA(ABS(CLOSE-LC),56,1)*100;
VARR6:=RSI1>RSI2 AND VARR5 AND VARR2;
VASS1:=HHV(H,30);
VASS2:=LLV(L,30);
VASS3:=REF((VASS1/VASS2-1)*100<=30,1);

A1:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,23))/EMA(CLOSE,23));
A2:=DMA(((2.15*CLOSE+LOW+HIGH)/4),A1);
游资:=EMA(A2,200)*1.1;
条件:=(C-REF(C,1))/REF(C,1)*100>5;
妖股:CROSS(C,游资) AND REF(C*1.097,1)<C AND VARR6 AND VASS3,NODRAW;

STICKLINE(IF(妖股,120,0),1.1,0,3,0),COLORRED;


DRAWTEXT(妖股,1.05,' 游资秘技'),COLORYELLOW;
来自驿站: 连板趋势

本帖寻求各位老师的解答

 南风北往2021-9-16 17:19发表回复被实施转采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

举报

使用道具 扔鸡蛋 回复

南风北往
Lv.2
发表于 2021-9-16 19:47 复制 查看全部楼层
可以:
妖股:=CROSS(C,游资) AND REF(C*1.097,1)<C AND VARR6 AND VASS3;
M天:REF(妖股,M);
M 你自己填上,比如昨天,M=1;前天,M=2;类推。把这两句替代原  妖股:=CROSS(C,游资) AND REF(C*1.097,1)<C AND VARR6 AND VASS3;这句即可。

举报

使用道具 点亮 支持 扔鸡蛋 回复

实施转
Lv.2
发表于 2021-9-16 19:36 复制 查看全部楼层
南风北往 发表于 2021-9-16 17:19
VARR1:=V;
VARR2:=VARR1>MA(V,89);
VARR3:=EXPMA(C,5);

大师可否在出一个专门设置那一天的选股公式,比如9月1日出现这个指标的公式。

举报

使用道具 点亮 支持 扔鸡蛋 回复

南风北往
Lv.2
发表于 2021-9-16 17:19 复制 查看全部楼层
VARR1:=V;
VARR2:=VARR1>MA(V,89);
VARR3:=EXPMA(C,5);
VARR4:=EXPMA(C,29);
VARR5:=VARR3>VARR4;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),56,1)/SMA(ABS(CLOSE-LC),56,1)*100;
VARR6:=RSI1>RSI2 AND VARR5 AND VARR2;
VASS1:=HHV(H,30);
VASS2:=LLV(L,30);
VASS3:=REF((VASS1/VASS2-1)*100<=30,1);

A1:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,23))/EMA(CLOSE,23));
A2:=DMA(((2.15*CLOSE+LOW+HIGH)/4),A1);
游资:=EMA(A2,200)*1.1;
条件:=(C-REF(C,1))/REF(C,1)*100>5;
妖股:CROSS(C,游资) AND REF(C*1.097,1)<C AND VARR6 AND VASS3;
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /6 下一条
回顶部 到页底
快速回复 返回顶部 返回列表