请老师给公式做个选股 谢谢老师!!!

[通达信]
设置
5622 16 高狮灯 Lv.3 发表于 · 2021-10-8 22:10 显示全部楼层 正序浏览 |
跳转到指定楼层
STICKLINE(L>REF(H,1) ,REF(H,1),L,9,-1),COLORFD00DF;
STICKLINE(H<REF(L,1) ,REF(L,1),H,9,-1),COLORFDFD00;
DRAWKLINE(H,O,L,C);
XA_1:=HIGH;
XA_2:=LOW;
XA_3:=REF(XA_1,10)=HHV(XA_1,2*10+1);
XA_4:=FILTER(XA_3,10);
XA_5:=BACKSET(XA_4,10+1);
XA_6:=FILTER(XA_5,10);
XA_7:=REF(XA_2,10)=LLV(XA_2,2*10+1);
XA_8:=FILTER(XA_7,10);
XA_9:=BACKSET(XA_8,10+1);
XA_10:=FILTER(XA_9,10);

DRAWNUMBER(FILTER(XA_5,10),HIGH,HIGH),LINETHICK9;
DRAWNUMBER(FILTER(XA_9,10),LOW,LOW);

DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,1) ;
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,2);         

XA_11:=(OPEN+CLOSE)/2;
XA_12:=REF(XA_11,1);
STICKLINE(ISLASTBAR,XA_12,XA_12,10,0),COLORWHITE;
DRAWNUMBER(ISLASTBAR,XA_12,XA_12);
XA_13:=REF(CLOSE,1);
XA_14:=REF(CLOSE,1)*1.1-CLOSE<0.01 AND HIGH=CLOSE;
STICKLINE(XA_14,OPEN,CLOSE,1,0),COLORRED;
STICKLINE(XA_14,HIGH,LOW,0,0),COLORRED;
XA_15:=IF((XA_13-CLOSE)*100/XA_13>=10-0.01*100/XA_13 AND LOW=CLOSE,1,0);
STICKLINE(XA_15,OPEN,CLOSE,1,0),COLORGREEN;
STICKLINE(XA_15,HIGH,LOW,0,1),COLORGREEN;
MA3:=MA(CLOSE,25);
MA4:=MA(CLOSE,60);
箱底:=TROUGH(CLOSE,10,1)*1.02,COLOR008888,LINETHICK2;
价低箱底:=COUNT(L<箱底,3);
底箱:=TROUGH(CLOSE,10,1)*1.05,COLOR008888,LINETHICK1;
DRAWTEXT(价低箱底>=1 AND 箱底<MA3 AND CROSS(C,底箱),L*0.999,'●杀入'),COLOR00CCCC;
DRAWTEXT(MA3>MA4 AND 价低箱底>=1 AND 箱底<MA3 AND CROSS(C,底箱),L*0.99,'●强杀入'),COLOR00CCCC;
A1:=REF(V,1);A2:=DVOL;
A3:=A2/A1;
LNX:=A3-REF(A3,1),COLOR00CCCC,LINETHICK1;
E1:=REF(C,1);E2:=DCLOSE;E3:=(E2-E1)/E1*100;
QMX:=E3-REF(E3,1),COLOR00CCCC,LINETHICK2;
XG:=CROSS(LNX,500) AND CROSS(QMX,10);
DRAWTEXT(XG=1,L*0.985,'---金指'),COLORYELLOW;
DRAWICON(XG=1,L*0.99,11);
ZF:=ABS(100*(H-L)/REF(C,1))>3;
DIF:=EMA(CLOSE,8)-EMA(CLOSE,13);
DEA:=EMA(DIF,6);
MACD:=2*(DIF-DEA);
金叉:=CROSS(DIF,DEA); 死叉:=CROSS(DEA,DIF);
DIF下拐:=REF(DIF,3)<REF(DIF,2)AND REF(DIF,2)<REF(DIF,1)AND REF(DIF,1)>DIF=REF(DIF,1);
MACD下拐:=REF(DIF,3)<REF(DIF,2)AND REF(MACD,2)<REF(MACD,1)AND REF(MACD,1)>MACD=REF(MACD,1);
下拐:=MAX(DIF下拐,MACD下拐);
GD1:=EVERY(DIF>REF(DIF,1),BARSLASTCOUNT(DIF>DEA))AND DIF>DEA;
GD2:=EVERY(MACD>REF(MACD,1),BARSLASTCOUNT(DIF>DEA))AND DIF>DEA;
GD:=MAX(GD1,GD2);
高点1:=REF(MAX(C,O),BARSLAST(GD1)+1);
高点2:=REF(MAX(C,O),BARSLAST(GD2)+1);
高点:=IF(高点2>=高点1,高点2,高点1);
AA:=HHV(IF(C>O,C,MAX(C,O)),BARSLASTCOUNT(高点)+1)=HHV(IF(C>O,C,MAX(C,O)),BARSLASTCOUNT(BBI>REF(BBI,1)AND C>BBI));

PP1:=BARSLAST(AA)=1;
YLX:=REF(MAX(C,O),BARSLAST(PP1)+1);
突破:CROSS(C,YLX),NODRAW,COLORWHITE;
STICKLINE(突破,C,O,2,0),COLORWHITE;
DIF突破:=REF(DIF,BARSLAST(PP1)+1);
有效突破:=突破 AND DIF>DIF突破;
STICKLINE(有效突破,C,O,2,0),COLORLIRED;
PP2:=BARSLAST(BB)=1;
ZCX:=REF(MIN(C,O),BARSLAST(PP2)+1);
破位:CROSS(ZCX,C),NODRAW,COLORLIGREEN;
STICKLINE(破位,C,O,2,0),COLORLIGREEN;
PP7:=BARSLAST(破位)=1;
破位K线:=REF(O,BARSLAST(PP7)+1);
突破破位:CROSS(C,破位K线),NODRAW,COLORLIMAGENTA;
STICKLINE(突破破位 AND C>O AND MACD>REF(MACD,1),C,O,2,0),COLORLIMAGENTA;
实体:=(C-O)/C=HHV((C-O)/C,15);
阳15:=C>O AND VOL>=HHV(VOL,15);
单阳:=(C>REF(C,1)*1.035 OR 实体)AND C>O AND (阳15 OR VOL>REF(VOL,1)*1.9),NODRAW,COLORYELLOW;
低不破价:=REF(O,BARSLAST(单阳));   请老师把金手指和强杀入分别做出选股公式  谢谢老师!!!

本帖寻求各位老师的解答

 和合而生2021-10-8 22:35发表回复被高狮灯采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

本主题由 任务系统 于 2021-10-8 22:25 审核通过

举报

使用道具 扔鸡蛋 回复

找到窍门
Lv.5
发表于 2021-10-9 11:05 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 点亮 支持 扔鸡蛋 回复

找到窍门
Lv.5
发表于 2021-10-9 11:04 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 点亮 支持 扔鸡蛋 回复

找到窍门
Lv.5
发表于 2021-10-9 10:51 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 点亮 支持 扔鸡蛋 回复

找到窍门
Lv.5
发表于 2021-10-9 10:47 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 点亮 支持 扔鸡蛋 回复

高狮灯
Lv.3
发表于 2021-10-8 22:58 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

高狮灯
Lv.3
发表于 2021-10-8 22:55 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南
点评
  • 高狮灯2021-10-8 22:58
    好滴谢谢老师!!!

举报

使用道具 支持 扔鸡蛋 回复

追丰990
Lv.2
发表于 2021-10-8 22:55 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 点亮 支持 扔鸡蛋 回复

追丰990
Lv.2
发表于 2021-10-8 22:50 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南
点评
  • 高狮灯2021-10-8 22:55
    谢谢老师可以的了不起,金手指不出股

举报

使用道具 支持 扔鸡蛋 回复

高狮灯
Lv.3
发表于 2021-10-8 22:49 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

和合而生
Lv.0
发表于 2021-10-8 22:47 复制 查看全部楼层
提示: 该帖已被屏蔽

举报

使用道具 支持 扔鸡蛋 回复

高狮灯
Lv.3
发表于 2021-10-8 22:46 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

高狮灯
Lv.3
发表于 2021-10-8 22:44 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

高狮灯
Lv.3
发表于 2021-10-8 22:40 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南
点评
  • 高狮灯2021-10-8 22:44
    第一个选不出来 第二个没有通过

举报

使用道具 支持 扔鸡蛋 回复

高狮灯
Lv.3
发表于 2021-10-8 22:39 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

追丰990
Lv.2
发表于 2021-10-8 22:37 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南
点评
  • 高狮灯2021-10-8 22:40
    谢谢老师帮助 再把强杀入来一个谢谢

举报

使用道具 支持 扔鸡蛋 回复

和合而生
Lv.0
发表于 2021-10-8 22:35 复制 查看全部楼层
提示: 该帖已被屏蔽

举报

使用道具 点亮 (2) 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表