请老师把一下主图公式改一下

[通达信]
设置
6703 1 多拉1987 Lv.2 发表于 · 2021-10-16 19:23 显示全部楼层 正序浏览 |
跳转到指定楼层
任务编号:9804605 悬赏任务10金钻 悬赏任务 : 按甲方需求进行任务后提交稿件,被采纳后即获得佣金。

请老师把一下主图公式改一下

距截止: 任务已圆满完成 甲方已托管赏金:10 金钻
甲方发布需求21.10.16 甲方托管佣金21.10.16 威客投稿21.10.16 甲方开始选稿21.10.16 任务完成21.10.22

任务大厅共需1个合格投稿 | 每稿将获得10 金钻 | 交稿后不可编辑,被拒稿后才可再次交稿。

投诉举报 联系Ta 我来承接 已有1 个投稿 | 已采纳1 稿 | 拒绝0 稿 | 目前中标名额已满

任务需求:
现在主图上面只显示均线数值,想加入“低吸,出击,坚决买入,逃顶”这几个指标,主图上出现是对应指标显示为1,否则就是0


公式如下:
MA13:MA(C,13),COLORWHITE;
MA34:MA(C,34),COLORFF00FF;
MA55:MA(C,55),COLORFFCC66;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
低吸:=CROSS(RSI,11);
DRAWTEXT(低吸,L,'★'),COLORWHITE;
DRAWTEXT(低吸,L-0.05,'低吸'),COLORWHITE;
VAR7:=EMA(AMOUNT/VOL/100,3);
VAR8:=EMA(VAR7,88);
VAR9:=EMA(VAR7,88)*0.85;
VARA:=VAR9*0.87;
VARB:=LOW<VARA AND CLOSE>REF(CLOSE,1)*1.02;
DRAWTEXT(FILTER(VARB,6),L-0.05,'坚决买进'),COLORFF00FF;
DRAWTEXT(FILTER(VARB,6),L,'★'),COLORFF00FF;
VARF:=(2*CLOSE+HIGH+LOW)/4;
VA4:=LLV(LOW,34);
VA5:=HHV(HIGH,34);
VA6:=EMA((VARF-VA4)/(VA5-VA4)*100,6);
VA7:=EMA(0.667*REF(VA6,1)+0.333*VA6,4);
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND REF(LOW,1)=LLV(LOW,120) AND
CLOSE>OPEN,1,0),L,'★'),COLORYELLOW;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND REF(LOW,1)=LLV(LOW,120) AND
CLOSE>OPEN,1,0),L-0.05,'出击'),COLORYELLOW;
A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/211;
D2:=EMA(D1,2);
D3:=EMA(D2,2);
K1:=EMA(D3,2);
DRAWTEXT(CROSS(D1,K1),L-0.05,'波段买入'),COLOR0099FF;
DRAWTEXT(CROSS(D1,K1),L,'★'),COLOR0099FF;
多方趋势:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1);
天线:=78.89;
STICKLINE(CROSS(天线,多方趋势),H*1.02,H*1.00,6,0),COLOR00FF00;
DRAWTEXT(CROSS(天线,多方趋势),H*1.04,'逃顶'),COLOR00FF00;

举报

使用道具 扔鸡蛋 回复

潇湘楚雲
Lv.3
发表于 2021-10-16 20:45 复制 查看全部楼层 屏蔽
已采纳
给他留言
附件: 您需要 登录 才可以下载或查看,没有帐号?

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表