帮忙把同花顺的附图指标改通达信附图

[通达信]
设置
6250 1 枫之舞0001 Lv.3 发表于 · 2021-10-25 13:24 显示全部楼层 正序浏览 |
跳转到指定楼层
{参数
N 1 100 9
M 1 100 26
D 1 100 4
G 1 100 15
E 1 100 5
J 1 100 40
X 1 100 46
T 1 100 7
P 1 100 2 }

FDGX:=1;
FDHN:=LLV(LOW,E);
FDBH:=LLV(LOW,N);
FDNT:=LLV(LOW,G);
FDSB:=LLV(LOW,J);
FDXG:=HHV(HIGH,D);
FDTS:=HHV(HIGH,N);
FDJP:=HHV(HIGH,G);
FDPT:=HHV(HIGH,J);
FDPB:=EMA(CLOSE,4,2);
FDGN:=EMA(CLOSE,12,3);
FDBS:=EMA(CLOSE,M,2);
FDSH:=EMA(CLOSE,100,3);
FDXT:=FDPB-FDSH;
FDJB:=FDGN-FDBS;
FDHP:=(HIGH+LOW+CLOSE)/3;
FDTG:=EMA(FDJB,9,4);
FDNX:=EMA(FDXT,9,5);
FDJT:=MA(FDHP,14);
FDHG:=(H+L+O+2*C)/5;
FDBJ:=(L+H+C)/3;
FDGP:=(((2*CLOSE)+HIGH)+LOW) / 4;
FDTJ:=LLV(LOW,X);
FDXS:=HHV(HIGH,X);
FDPG:=FDGP-FDHN;
FDNH:=FDXG-FDHN;
FDSX:=FDPT-FDSB;
FDNJ:=FDJP-FDNT;
FDHX:=FDTS-FDBH;
FDGH:=FDXT-FDNX;
FDSP:=FDGP-FDTJ;
FDJN:=FDXS-FDTJ;
FDPJ:=(CLOSE-FDNT)/FDNJ*100;
FDBG:=((CLOSE-FDBH)/FDHX)*100;
FDXN:=SMA(FDBG,3,1);
FDTB:=SMA(FDXN,3,1);
FDJG:=SMA(FDPJ,6,1);
FDTX:=SMA(FDJG,3,1);
FDPH:=SMA(FDTX,2,1);
FDGJ:=FDTX<=FDPH;
FDXB:=FDTX>FDPH;
FDBN:=IF(C,1,0);
FDNP:=(C*2+H+L)/4;
FDHT:=EMA(FDNP,8) - EMA(FDNP,30);
FDST:=EMA(FDHT,10);
FDNB:=2*(FDTG-FDJB);
FDGS:=3*FDXN-2*FDTB;
FDTH:=(2*(FDHT-FDST))*3;
FDSN:=EMA(((FDPG/FDNH)*100),4)*FDGX;
FDBX:=EMA(((0.7*REF(FDSN,1))+(0.3*FDSN)),1)*FDGX;
辅:((EMA(((FDPG/FDNH)*100),4)*FDGX)-52)*2;
趋:(EMA(100*(C-FDSB)/FDSX,8)-48)*2,COLORFFFF33;
MACD:2*(FDJB-FDTG),COLORSTICK;
KDJ:(FDXN-FDTB)*2,COLORSTICK;
JCCOUNT:=COUNT(CROSS(FDJB,FDTG),BARSLAST(FDTG>=0));
FDSG:=CROSS(FDJB,FDTG) AND FDTG<=0 AND COUNT(JCCOUNT=2,21)=1;
FDPS:=REF(FDTH,1)>FDTH;
FDSJ:=REF(FDTH,1)<=FDTH;
FDNS:=BARSLAST(REF(CROSS(FDSN,FDBX),1));
FDGB:=BARSLAST(REF(CROSS(FDBX,FDSN),1));
FDJX:=(VOL>=1.90*REF(VOL,1))*FDBN AND C>REF(C,1) AND KDJ>0;
FDXP:=(VOL>=1.90*REF(VOL,1))*FDBN AND C>REF(C,1) AND KDJ<0;
FDHJ:=100*EMA(EMA((C-REF(C,1)),6),6)/EMA(EMA(ABS((C-REF(C,1))),6),6);
FDHB:=FDGH<0 AND FDGH>REF(FDGH ,1) AND REF(FDGH ,1)<REF(FDGH ,2)
AND REF(FDGH ,2)<REF(FDGH ,3)
AND REF(FDGH ,3)<REF(FDGH ,4);
FDJH:=LLV(FDHJ,2)=LLV(FDHJ,7) AND COUNT(FDHJ<0,2) AND CROSS(FDHJ,MA(FDHJ,2));
FDPX:=(VOL=LLV(VOL,100))*FDBN;
FDBT:=(VOL*1.98<=REF(VOL,1))*FDBN AND KDJ>0;
FDXJ:=(VOL*1.98<=REF(VOL,1))*FDBN AND KDJ<0;
FDXH:=REF(CLOSE,FDNS+1)>CLOSE AND FDSN>REF(FDSN,FDNS+1) AND CROSS(FDSN,FDBX);
FDGT:=REF(CLOSE,FDGB+1)<CLOSE AND REF(FDBX,FDGB+1)>FDBX AND CROSS(FDBX,FDSN);
KJD:=(FDXN-FDTB)/1;
高抛价:FDHG*2-L,COLORRED;
抄底价:FDHG*2-H,COLORGREEN;
短线价:MA(FDBJ,5),COLOR0099FF;
中线价:LLV(FDBJ,13),COLORFF9900;
量能度:IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,
(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100),COLOR2DFFFF;
STICKLINE(KDJ>=0 AND FDNB<=0 ,76,64,2,0),COLOR0000A8;
STICKLINE(KDJ<=0 AND FDNB>=0 ,76,64,2,0),COLOR008800;
STICKLINE(FDNB<0,80,77,6,0),COLOR0000A8;
STICKLINE(FDNB>0,80,77,6,0),COLOR008800;
STICKLINE(FDNB<0,60,63,6,0),COLOR0000A8;
STICKLINE(FDNB>0,60,63,6,0),COLOR008800;
STICKLINE((CROSS(FDJB,FDTG) AND FDJB<=0),76,64,4,0),COLOR98FB98;
STICKLINE((CROSS(FDJB,FDTG) AND FDJB>0),76,64,4,0),COLOR0099FF;
STICKLINE(FDSG,73,67,4,0),COLORRED;
STICKLINE(KDJ>0,KDJ,-2,6,0),COLORAF60FF;
STICKLINE(KDJ<0,KDJ,2,6,0),COLORGREEN;
DRAWTEXT(FDJX,-5,'放'),COLORB0C4DE;
DRAWTEXT(FDXP,25,'放'),COLORB0C4DE;
DRAWTEXT(FDBT,-5,'缩'),COLORFF8899;
DRAWTEXT(FDXJ,25,'缩'),COLORFF8899;
DRAWTEXT(FDPX,35,'百'),COLOR98FB98;
DRAWTEXT(CROSS(99,FDGS),60,'回'),COLORFF6EC7;
DRAWTEXT(CROSS(120,FDGS),63,'顶'),COLOR0099FF;
DRAWTEXT(CROSS(FDGS,130) AND KDJ<REF(KDJ ,1),63,'顶'),COLOR0099FF;
DRAWTEXT(CROSS(FDGS,110) AND KDJ<REF(KDJ ,1),63,'顶'),COLOR0099FF;
DRAWTEXT(CROSS(FDGS,5),-37,'反'),COLORFFAACC;
DRAWTEXT(FDXH>0,-40,'底'),COLORFF8855;
DRAWTEXT(FDGT>0,63,'顶'),COLOR0099FF;
STICKLINE(FDSJ,-80,-75,8,0),COLOR0000A8;
STICKLINE(FDPS,-80,-75,8,0),COLOR02FF9A;
STICKLINE(FDSJ,-63,-60,8,0),COLOR0000A8;
STICKLINE(FDPS,-63,-60,8,0),COLOR02FF9A;
STICKLINE(FDHB,44,30,2,0),COLORGRAY;
STICKLINE(FDHB,60,44,4,0),COLORRED;
STICKLINE(FDJH,-59,-47,4,0),COLORRED;
STICKLINE(FDJH,-74,-64,4,0),COLORRED;
STICKLINE(CROSS(-10,FDGS),-74,-64,3,0),COLORRED;
STICKLINE(CROSS(FDGS,-5),-74,-64,3,0),COLORRED;
STICKLINE(CROSS(FDSN,50),-74,-64,4,0),COLORFF0088;
STICKLINE(CROSS(FDSN,50),-40,-59,4,0),COLORFF0088;
PARTLINE(趋,FDXB,RGB(255,0,255),FDGJ,RGB(0,255,255)),LINETHICK1;

再帮忙做3个选股两个是红色柱选股一个是紫色柱选股

本帖寻求各位老师的解答

 注册1112021-10-25 16:51发表回复被枫之舞0001采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

举报

使用道具 扔鸡蛋 回复

注册111
Lv.6
发表于 2021-10-25 16:51 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。

举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表