请老师帮助写飞狐交易师公式

[其他股软] 7652 1
设置
1381127 Lv.2

专栏

发表于 2021-10-25 20:43 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
任务编号:9813615 悬赏任务15金钻 悬赏任务 : 按甲方需求进行任务后提交稿件,被采纳后即获得佣金。

请老师帮助写飞狐交易师公式

距截止: 任务已圆满完成 甲方已托管赏金:15 金钻
甲方发布需求21.10.25 甲方托管佣金21.10.25 威客投稿21.10.25 甲方开始选稿21.10.29 任务完成21.10.29

任务大厅共需1个合格投稿 | 每稿将获得15 金钻 | 交稿后不可编辑,被拒稿后才可再次交稿。

投诉举报 联系Ta 我来承接 已有1 个投稿 | 已采纳0 稿 | 拒绝1 稿 | 还需要1 稿

任务需求:
请老师帮助写飞狐交易师公式

请老师把条件1单独写一个选股
          把条件1--条件4合成写一个选股
  
条件1 宝塔线下穿宝塔布林指标的布林下轨且当日翻红(宝塔布林指标附后)。

条件2 自条件1信号出现后3个交易日内某日开盘向上跳空0.51%--2.55%信号成立。

条件3 向上跳空前连续2个交易日均为红色且相对于昨日收盘上涨的阳K线。

条件4 自条件1向前15个交易日无单日涨跌幅大于9.9%的情况  自条件1向前50个交易日无2日或2日以上(包括连续或间断2日)涨跌幅大于9.9%的情况。

举例说明
1 第一天条件1信号+第二天阳+第3天开盘向上跳空
000918        19.02.12
002712        19.08.12
000333        21.05.12
2 第一天阳+第二天条件1信号+第3天开盘向上跳空
000055        18.06.04
600160        14.12.12
002907    21.10.11
3 第一天条件1信号+第二天阳+第3天阳+第4天开盘向上跳空
002757        18.01.04
000558    21.05.14

宝塔布林指标
N :26
P :2

MID:MA(CLOSE,N);
UPPER:MID+P*STD(CLOSE,N);
LOWER:MID-P*STD(CLOSE,N);
Var1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
Var2:=REF(Var1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var3:=REF(Var2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var4:=REF(Var3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var5:=REF(Var4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var6:=REF(Var5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var7:=REF(Var6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var8:=REF(Var7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var9:=REF(Var8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VarA:=REF(Var9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VarB:=REF(VarA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VarC:=REF(VarB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
STICKLINE(Var1 OR Var2 OR Var3 OR Var4 OR Var5 OR Var6 OR Var7 OR Var8 OR Var9 OR VarA OR VarB OR VarC,CLOSE,REF(CLOSE,1),5,1),COLORRED;
VarD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VarE:=REF(VarD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VarF:=REF(VarE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var10:=REF(VarF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var11:=REF(Var10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var12:=REF(Var11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var13:=REF(Var12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var14:=REF(Var13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var15:=REF(Var14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var16:=REF(Var15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
Var17:=REF(Var16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
Var18:=REF(Var17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
STICKLINE(VarD OR VarE OR VarF OR Var10 OR Var11 OR Var12 OR Var13 OR Var14 OR Var15 OR Var16 OR Var17 OR Var18,CLOSE,REF(CLOSE,1),5,0),colorcyan;
Var19:=REF(VarD OR VarE OR VarF OR Var10 OR Var11 OR Var12 OR Var13 OR Var14 OR Var15 OR Var16 OR Var17 OR Var18,1) AND Var1;
STICKLINE(Var19,REF(CLOSE,1),REF(CLOSE,2),5,0),colorgreen;
Var1A:=REF(Var1 OR Var2 OR Var3 OR Var4 OR Var5 OR Var6 OR Var7 OR Var8 OR Var9 OR VarA OR VarB OR VarC,1) AND VarD;
STICKLINE(Var1A,REF(CLOSE,1),REF(CLOSE,2),5,1),COLORRED;
附件: 您需要 登录 才可以下载或查看,没有帐号?

举报

使用道具 扔鸡蛋 回复

2599688
Lv.5

专栏

发表于 2021-10-25 21:18 复制 查看全部楼层 屏蔽
已拒绝
该稿件已被甲方拒绝,理由是:
反复修改后不符合要求。已给写公式的老师附表格列出符合条件但提供的选股公式依然无法选出的股票代码 日期 写公式的老师认为不划算。所以拒绝采纳此稿件
附件: 您需要 登录 才可以下载或查看,没有帐号?

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表