求老师修改分时指标

[改 写] 8732 42
设置
3839246 Lv.3

专栏

发表于 2021-11-18 16:01 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
求老师修改分时叠加k线指标添加5、10、20、60日均线,添加涨跌停变色,谢谢!

111.jpg



引用公式 名称 分时引用6K

{分时量}
今量:VOL;
MA5:MA(C,5);
MA10:MA(C,10);

{虚拟成交量}
TOTAL:=IF(PERIOD=5,240,1);
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
虚量:IF(CURRBARSCOUNT=1,V*TOTAL/CTIME,V),NODRAW;
昨量:REF(VOL,1);
前量:REF(VOL,2);
再前量:REF(VOL,3);
昨均价:REF(AMOUNT/VOL/100,1);
O1:REF(O,1);
C1:REF(C,1);
H1:REF(H,1);
L1:REF(L,1);

O2:REF(O,2);
C2:REF(C,2);
H2:REF(H,2);
L2:REF(L,2);

O3:REF(O,3);
C3:REF(C,3);
H3:REF(H,3);
L3:REF(L,3);

O4:REF(O,4);
C4:REF(C,4);
H4:REF(H,4);
L4:REF(L,4);

O5:REF(O,5);
C5:REF(C,5);
H5:REF(H,5);
L5:REF(L,5);

O6:REF(O,6);
C6:REF(C,6);
H6:REF(H,6);
L6:REF(L,6);

O7:REF(O,7);
C7:REF(C,7);
H7:REF(H,7);
L7:REF(L,7);

O8:REF(O,8);
C8:REF(C,8);
H8:REF(H,8);
L8:REF(L,8);

O9:REF(O,9);
C9:REF(C,9);
H9:REF(H,9);
L9:REF(L,9);

=======================
主图


O9:="分时引用6K.O9#DAY";
C9:="分时引用6K.C9#DAY";
H9:="分时引用6K.H9#DAY";
L9:="分时引用6K.L9#DAY";
O8:="分时引用6K.O8#DAY";
C8:="分时引用6K.C8#DAY";
H8:="分时引用6K.H8#DAY";
L8:="分时引用6K.L8#DAY";
O7:="分时引用6K.O7#DAY";
C7:="分时引用6K.C7#DAY";
H7:="分时引用6K.H7#DAY";
L7:="分时引用6K.L7#DAY";
O6:="分时引用6K.O6#DAY";
C6:="分时引用6K.C6#DAY";
H6:="分时引用6K.H6#DAY";
L6:="分时引用6K.L6#DAY";

O5:="分时引用6K.O5#DAY";
C5:="分时引用6K.C5#DAY";
H5:="分时引用6K.H5#DAY";
L5:="分时引用6K.L5#DAY";
O4:="分时引用6K.O4#DAY";
C4:="分时引用6K.C4#DAY";
H4:="分时引用6K.H4#DAY";
L4:="分时引用6K.L4#DAY";
再前开:="分时引用6K.O3#DAY";
再前收:="分时引用6K.C3#DAY";
H3:="分时引用6K.H3#DAY";
L3:="分时引用6K.L3#DAY";
前开:="分时引用6K.O2#DAY";
前收:="分时引用6K.C2#DAY";
H2:="分时引用6K.H2#DAY";
L2:="分时引用6K.L2#DAY";
昨开:="分时引用6K.O1#DAY";
昨收:=DYNAINFO(3);{昨收:="分时引用.C1#DAY"}
昨高:="分时引用6K.H1#DAY";
昨低:="分时引用6K.L1#DAY";
今开:=DYNAINFO(4);{今开}
今收:=DYNAINFO(7);{现价}
今高:=DYNAINFO(5);
今低:=DYNAINFO(6);
HH1:=MAX(昨高,H2);
HH2:=MAX(H3,H4);
HH3:=MAX(MAX(今高,H5),MAX(HH1,HH2));
LL1:=MIN(昨低,L2);
LL2:=MIN(L3,L4);
LL3:=MIN(MIN(今低,L5),MIN(LL1,LL2));
开关:=1;{开关=0, K线画在下半区域;开关=1, K线画在上半区域;开关=2, K线画在全区域}

PP:=IF(开关=0,1,IF(开关=1,1,IF(开关=2,1,DRAWNULL)));
H1H3:=IF(PP,500,IF(PP,999,999));
L1L3:=IF(PP,0,IF(PP,300,0));
HL:=(H1H3-L1L3)/(HH3-LL3);
C92:=999-(L1L3+(C9-LL3)*HL);
H92:=999-(L1L3+(H9-LL3)*HL);
L92:=999-(L1L3+(L9-LL3)*HL);
O92:=999-(L1L3+(O9-LL3)*HL);

C82:=999-(L1L3+(C8-LL3)*HL);
H82:=999-(L1L3+(H8-LL3)*HL);
L82:=999-(L1L3+(L8-LL3)*HL);
O82:=999-(L1L3+(O8-LL3)*HL);

C72:=999-(L1L3+(C7-LL3)*HL);
H72:=999-(L1L3+(H7-LL3)*HL);
L72:=999-(L1L3+(L7-LL3)*HL);
O72:=999-(L1L3+(O7-LL3)*HL);

C62:=999-(L1L3+(C6-LL3)*HL);
H62:=999-(L1L3+(H6-LL3)*HL);
L62:=999-(L1L3+(L6-LL3)*HL);
O62:=999-(L1L3+(O6-LL3)*HL);

C52:=999-(L1L3+(C5-LL3)*HL);
H52:=999-(L1L3+(H5-LL3)*HL);
L52:=999-(L1L3+(L5-LL3)*HL);
O52:=999-(L1L3+(O5-LL3)*HL);
C42:=999-(L1L3+(C4-LL3)*HL);
H42:=999-(L1L3+(H4-LL3)*HL);
L42:=999-(L1L3+(L4-LL3)*HL);
O42:=999-(L1L3+(O4-LL3)*HL);
C32:=999-(L1L3+(再前收-LL3)*HL);
H32:=999-(L1L3+(H3-LL3)*HL);
L32:=999-(L1L3+(L3-LL3)*HL);
O32:=999-(L1L3+(再前开-LL3)*HL);
C22:=999-(L1L3+(前收-LL3)*HL);
H22:=999-(L1L3+(H2-LL3)*HL);
L22:=999-(L1L3+(L2-LL3)*HL);  
O22:=999-(L1L3+(前开-LL3)*HL);
C12:=999-(L1L3+(昨收-LL3)*HL);
H12:=999-(L1L3+(昨高-LL3)*HL);
L12:=999-(L1L3+(昨低-LL3)*HL);  
O12:=999-(L1L3+(昨开-LL3)*HL);
C02:=999-(L1L3+(今收-LL3)*HL);
H02:=999-(L1L3+(今高-LL3)*HL);
L02:=999-(L1L3+(今低-LL3)*HL);
O02:=999-(L1L3+(今开-LL3)*HL);
{6日K线}

N1:=IF(FROMOPEN>120,200,IF(FROMOPEN<=120,700,70));
Q01:=IF(今收<昨低,0,IF(今收>昨高,60,100));
Q02:=IF(今收<昨低,100,IF(今收>昨高,0,100));

Q1:=IF(今收>=今开,250,0);
Q2:=IF(今收>=今开,0,250);
{今日K线}
DRAWRECTREL(N1-49,H02,N1-49,L02,RGB(Q1,Q2,0));
DRAWRECTREL(N1-55,C02,N1-43,O02,RGB(Q1,Q2,0));
{昨日K线}
DRAWRECTREL(N1-64,H12,N1-64,L12,RGB(IF(昨收>=昨开,200,0),IF(昨收>=昨开,0,200),0));
DRAWRECTREL(N1-70,C12,N1-58,O12,RGB(IF(昨收>=昨开,128,0),IF(昨收>=昨开,0,128),0));
{前日K线}
DRAWRECTREL(N1-79,H22,N1-79,L22,RGB(IF(前收>=前开,200,0),IF(前收>=前开,0,200),0));
DRAWRECTREL(N1-85,C22,N1-73,O22,RGB(IF(前收>=前开,128,0),IF(前收>=前开,0,128),0));
{大前日K线}
DRAWRECTREL(N1-94,H32,N1-94,L32,RGB(IF(再前收>=再前开,200,0),IF(再前收>=再前开,0,200),0));
DRAWRECTREL(N1-100,C32,N1-88,O32,RGB(IF(再前收>=再前开,128,0),IF(再前收>=再前开,0,128),0));

DRAWRECTREL(N1-109,H42,N1-109,L42,RGB(IF(C4>=O4,200,0),IF(C4>=O4,0,200),0));
DRAWRECTREL(N1-115,C42,N1-103,O42,RGB(IF(C4>=O4,128,0),IF(C4>=O4,0,128),0));

DRAWRECTREL(N1-124,H52,N1-124,L52,RGB(IF(C5>=O5,200,0),IF(C5>=O5,0,200),0));
DRAWRECTREL(N1-130,C52,N1-118,O52,RGB(IF(C5>=O5,128,0),IF(C5>=O5,0,128),0));

DRAWRECTREL(N1-139,H62,N1-139,L62,RGB(IF(C6>=O6,200,0),IF(C6>=O6,0,200),0));
DRAWRECTREL(N1-145,C62,N1-133,O62,RGB(IF(C6>=O6,128,0),IF(C6>=O6,0,128),0));


DRAWRECTREL(N1-154,H72,N1-154,L72,RGB(IF(C7>=O7,200,0),IF(C7>=O7,0,200),0));
DRAWRECTREL(N1-160,C72,N1-148,O72,RGB(IF(C7>=O7,128,0),IF(C7>=O7,0,128),0));


DRAWRECTREL(N1-169,H82,N1-169,L82,RGB(IF(C8>=O8,200,0),IF(C8>=O8,0,200),0));
DRAWRECTREL(N1-175,C82,N1-163,O82,RGB(IF(C8>=O8,128,0),IF(C8>=O8,0,128),0));


DRAWRECTREL(N1-184,H92,N1-184,L92,RGB(IF(C9>=O9,200,0),IF(C9>=O9,0,200),0));
DRAWRECTREL(N1-190,C92,N1-178,O92,RGB(IF(C9>=O9,128,0),IF(C9>=O9,0,128),0));

本帖寻求各位老师的解答

 阿敏20102021-11-20 13:40发表回复被赢时而动采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

举报

使用道具 扔鸡蛋 回复

3839246
Lv.3

专栏

发表于 2021-12-31 19:53 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
  • 阿敏2010+20理想币 : 祝你2022年,更上一层楼,年年有新高!
查看全部打赏

举报

使用道具 点亮 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-23 12:18 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
查看全部打赏

举报

使用道具 支持 扔鸡蛋 回复

3839246
Lv.3

专栏

发表于 2021-11-23 10:33 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-23 10:18 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 支持 扔鸡蛋 回复

3839246
Lv.3

专栏

发表于 2021-11-23 08:47 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-22 15:06 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

附件

2021-11-22.png
查看全部打赏

举报

使用道具 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-22 12:32 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
  • 赢时而动+10理想币 : 谢谢老师帮忙中给予帮助!
查看全部打赏

举报

使用道具 点亮 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-22 11:12 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-22 09:12 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 支持 扔鸡蛋 回复

3839246
Lv.3

专栏

发表于 2021-11-22 07:16 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-21 21:30 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

附件

2021-11-21 (1).png

举报

使用道具 支持 扔鸡蛋 回复

3839246
Lv.3

专栏

发表于 2021-11-21 20:54 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-21 17:49 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
  • 赢时而动+10理想币 : 点赞,知识的价值在于分享,谢谢!感恩老师!
查看全部打赏

举报

使用道具 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-21 17:48 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-21 17:43 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 支持 扔鸡蛋 回复

3839246
Lv.3

专栏

发表于 2021-11-21 17:17 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-21 14:08 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
查看全部打赏

举报

使用道具 点亮 支持 扔鸡蛋 回复

3839246
Lv.3

专栏

发表于 2021-11-21 13:03 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-21 11:04 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

附件

2021-11-21.png
分时K线重叠.tn6

11.59 KB, 下载次数: 2, 下载积分: 共享币 -10 个

查看全部打赏

举报

使用道具 点亮 支持 扔鸡蛋 回复

3839246
Lv.3

专栏

发表于 2021-11-21 09:57 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

3893400
Lv.1

专栏

发表于 2021-11-20 22:21 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-20 20:42 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
查看全部打赏

举报

使用道具 点亮 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-20 19:27 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
  • 赢时而动+10理想币 : 感恩老师!这个指标能加均线吗?
查看全部打赏

举报

使用道具 点亮 支持 扔鸡蛋 回复

3839246
Lv.3

专栏

发表于 2021-11-20 18:04 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-20 17:41 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

附件

2021-11-20 (2).png

举报

使用道具 点亮 支持 扔鸡蛋 回复

3839246
Lv.3

专栏

发表于 2021-11-20 16:25 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

3839246
Lv.3

专栏

发表于 2021-11-20 14:01 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

2208944
Lv.3

专栏

发表于 2021-11-20 13:40 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。

附件

2021-11-20 (1).png
sss.tn6

17.03 KB, 下载次数: 2, 下载积分: 共享币 -10 个

查看全部打赏

举报

使用道具 点亮 支持 扔鸡蛋 回复

3839246
Lv.3

专栏

发表于 2021-11-20 13:22 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主 15楼
32楼 14楼
31楼 13楼
30楼 12楼
29楼 11楼
28楼 10楼
27楼 9楼
26楼 8楼
25楼 7楼
24楼 6楼
23楼 5楼
22楼 4楼
21楼  
20楼  
19楼  
18楼  
17楼  
16楼  
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表