请老师将副图公式 中 DIF线 做个选股

[通达信]
设置
1900 3 想好再说 Lv.3 发表于 · 2021-11-25 10:44 显示全部楼层 正序浏览 |
跳转到指定楼层
请老师将副图公式 中DIF做个选股,谢谢!
1.  请将 DIF线 当天 由白变红时做个选股。
2.  请将 DIF线当天 白线V型上拐时做个选股。


SHORT:=12 ;  LONG:=26 ;  M:=9;

总涨跌比:=DYNAINFO(60)/(DYNAINFO(60)+DYNAINFO(61))*100,COLORCYAN,NODRAW;
DRAWTEXT_FIX(1,0.2,0.0,0,STRCAT('总涨跌比: ',CON2STR(总涨跌比,2))),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.005,0,0,STRCAT('主营同比: ',CON2STR(FINANCE(44),2))),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,STRCAT('利润同比: ',CON2STR(FINANCE(43),2))),COLORGREEN;
SBL:= STRCAT(STRCAT(STRCAT(HYBLOCK,DYBLOCK),GNBLOCK),ZDBLOCK);
DRAWTEXT_FIX(1,0.4,0,0,SBL),COLOR0090FF;


DIFF:=(EMA(CLOSE,SHORT) - EMA(CLOSE,LONG)),DOTLINE;
DEA:=EMA(DIFF,M),POINTDOT;
MACD2:=(2 * (DIFF - DEA));
STICKLINE((MACD2>=0),0,MACD2,2.8,-1),COLOR0000FF;
STICKLINE(((MACD2>=0) AND (MACD2 < REF(MACD2,1))),0,MACD2,2,0),COLOR0090FF;
STICKLINE((MACD2<0),0,MACD2,2,0)COLORCYAN;
STICKLINE(((MACD2<0) AND (MACD2 > REF(MACD2,1))),0,MACD2,2.8,-1),COLORCYAN;
STICKLINE(DIFF<0 AND MACD2<0,0,MACD2,2.8,-1),,COLORGREEN;
STICKLINE(DIFF<0 AND MACD2>0,0,MACD2,2.8,-1),,COLORCYAN;
STICKLINE(((DIFF<0) AND (MACD2 < REF(MACD2,1))),0,MACD2,2,0),,COLORGREEN;
DRAWICON(((((HHV(MACD2,4) < 0) AND (MACD2 > REF(MACD2,1))) AND (REF(MACD2,1) < REF(MACD2,2))) AND (REF(MACD2,2) < REF(MACD2,3)))AND DIFF>0 AND DIFF>REF(DIFF,1),MACD2,30),NODRAW;



DIF:DIFF,LINETHICK2,COLORWHITE;
DEF:DEA,LINETHICK1,COLORYELLOW,POINTDOT;
IF(DIFF>=REF(DIFF,1),DIFF,DRAWNULL),COLORRED,LINETHICK4;
翻红:=MACD2>REF(MACD2,1) AND REF(MACD2,1)<REF(MACD2,2) AND REF(MACD2,2)<REF(MACD2,3)AND DEA>0 AND DIFF>0 AND DIFF>REF(DIFF,1) AND MACD2>0.01;
DRAWICON(翻红 AND DEA>0,-0.01,29),NODRAW;
DRAWICON(CROSS(DIFF,0),-0.01,38);
STICKLINE(CROSS(DIFF,0),0,MACD2,3,0)COLORMAGENTA;
STICKLINE(CROSS(0,DIFF),0,MACD2,3,0)COLORWHITE;
DRAWICON(CROSS(0,DIFF),0,39);
DRAWICON(CROSS(DIFF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIFF)AND DIFF>0,DEA,2);
IF(DEF<=0,DEF,DRAWNULL),COLORBLUE,LINETHICK1,NODRAW;



{柱变与交叉临界}
开盘价格:=O,COLORYELLOW,NODRAW;
收盘价格:=C,COLORYELLOW,NODRAW;
最高价格:=H,COLORYELLOW,NODRAW;
最低价格:=L,COLORYELLOW,NODRAW;
振幅:=(H-L)/REF(C,1)*100,COLORYELLOW,NODRAW;


柱变临界:  (EMA(CLOSE,12)*1134-EMA(CLOSE,26)*910-DEA*702)/224,COLORLIBLUE,NODRAW;
交叉临界:351/28*(EMA(DIFF,9)-11/13*EMA(C,12)+25/27*EMA(C,26)),COLORLIBLUE,NODRAW;
ES:=REF(EMA(C,26),1);
EP:=REF(EMA(C,12),1);
DI:=REF(DIFF,1);
DIF拐点价:((12-1)*EP/(12+1)-(26-1)*ES/(26+1)-DI)*(26+1)*(12+1)/(2*(12+1)-2*(26+1)),COLORYELLOW,NODRAW;
换手率:VOL/CAPITAL*100,COLORWHITE,NODRAW;
十日换手:SUM(V/CAPITAL*100,10),COLOR0099FF,NODRAW;
获利盘:WINNER(C)*100 ,COLORRED,NODRAW;
当日获利套牢:获利盘-REF(获利盘,1),NODRAW;


DIF1:REF(HHV(DEA,BARSLAST(CROSS(DEA,DIF))+1),1),COLORGREEN,LINETHICK2;
DIF2:REF(LLV(DEA,BARSLAST(CROSS(DIF,DEA))+1),1),COLORMAGENTA,LINETHICK2;

交叉价格:=351/28*(EMA(DIFF,9)-11/13*EMA(C,12)+25/27*EMA(C,26)),COLORLIBLUE,NODRAW;
DRAWTEXT_FIX(1,0.9,1,0,STRCAT('交叉价格: ',CON2STR(交叉价格,2))),COLORGREEN;

本帖寻求各位老师的解答

 霖哥2021-11-25 12:49发表回复被想好再说采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

举报

使用道具 扔鸡蛋 回复

霖哥
Lv.3
发表于 2021-11-25 14:34 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

想好再说
Lv.3
发表于 2021-11-25 14:31 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南
点评
  • 霖哥2021-11-25 14:34
    不用客气

举报

使用道具 点亮 支持 扔鸡蛋 回复

霖哥
Lv.3
发表于 2021-11-25 12:49 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。
点评
  • 想好再说2021-11-25 14:31
    感谢 霖哥 高手老师!选股做得很好,是我所希望要的。

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表