请老师把益盟分时指标改成通达信用的,谢谢

[改 写]
设置
2727 9 飞向热点 Lv.3 发表于 · 2021-11-25 12:22 显示全部楼层 正序浏览 |
跳转到指定楼层
本帖最后由 飞向热点 于 2021-11-25 12:24 编辑

白线在上 (0, 1, 0, 1);   {这里是益盟的参数设置}




变盘:=0;
区间:=2;
有效期:=1;
AA:=MAX(DYNAINFO(3),DYNAINFO(5));昨收:=INTPART((DYNAINFO(3)));今开:=INTPART((DYNAINFO(4)));
BB:=MIN(DYNAINFO(3),DYNAINFO(6));缺口:=(DYNAINFO(4) - DYNAINFO(3));
量比:=(((SUM(V,0) * THISDAY) / DYNAINFO(38)) / BARSCOUNT(C));时间:=BARSCOUNT(C);
C1000:=IF((时间 = 30),C,REF(C,(时间 - 30)));
C1130:=IF((时间 = 120),C,REF(C,(时间 - 120)));
C0929:=IF((时间 = 29),C,REF(C,(时间 - 29)));
H1000:=IF((时间 = 30),HHV(C,时间),REF(HHV(C,30),(时间 - 30)));
L1000:=IF((时间 = 30),LLV(C,时间),REF(LLV(C,30),(时间 - 30)));

K线涨幅:=IF((时间 = 30),(V / REF(V,1)),REF((V / REF(V,1)),(时间 - 30)));
H10:=INTPART((H1000));
L10:=INTPART((L1000));
C10:=INTPART((C1000));
10点量比:=IF((时间 = 30),量比,REF(量比,(时间 - 30)));
委比:=(((ALLBIDVOL - ALLASKVOL) / (ALLASKVOL + ALLBIDVOL)) * 100);

X:=(((((3 * C) + L) + O) + H) / 6);
Y:=(((((((((((((((((((((20 * X) + (19 * REF(X,1))) + (18 * REF(X,2))) + (17 * REF(X,3))) + (16 * REF(X,4))) + (15 * REF(X,5))) + (14 * REF(X,6))) + (13 * REF(X,7))) + (12 * REF(X,8))) + (11 * REF(X,9))) + (10 * REF(X,10))) + (9 * REF(X,11))) + (8 * REF(X,12))) + (7 * REF(X,13))) + (6 * REF(X,14))) + (5 * REF(X,15))) + (4 * REF(X,16))) + (3 * REF(X,17))) + (2 * REF(X,18))) + REF(X,20)) / 210);
半缺:=INTPART((ABS((DYNAINFO(4) - DYNAINFO(3))) / 2));
半半缺:=INTPART((ABS((DYNAINFO(4) - DYNAINFO(3))) / 4));
TJA:=(((今开 = 昨收) && (变盘 = 0)) && (10点量比 > 1));
PK1:=(TJA && (C10 > 昨收));
PK2:=(TJA && (C10 = 昨收));
PK3:=(TJA && (C10 < 昨收));
TJB:=((((今开 > 昨收) && (L10 > 昨收)) && (变盘 = 0)) && (10点量比 > 1));
GK1:=((TJB && (C10 > (昨收 + 半缺))) && (C10 <= 今开));
GK2:=(TJB && (C10 = (昨收 + 半缺)));
GK3:=((TJB && (C10 >= 昨收)) && (C10 < (昨收 + 半缺)));
GK0:=(TJB && (C10 > 今开));
TJ3:=((((今开 > 昨收) && (L10 = 昨收)) && (变盘 = 0)) && (10点量比 > 1));
GK4:=(TJ3 && (C10 > (昨收 + 半半缺)));
GK5:=(TJ3 && (C10 = (昨收 + 半半缺)));
GK6:=(TJ3 && (C10 < (昨收 + 半半缺)));
TJ4:=((((今开 > 昨收) && (L10 < 昨收)) && (变盘 = 0)) && (10点量比 > 1));
GK7:=(TJ4 && (C10 > 今开));
GK8:=(TJ4 && (C10 = 今开));
GK9:=(TJ4 && (C10 < 今开));
TJ5:=((((今开 < 昨收) && ((昨收 - 今开) <= 20)) && (变盘 = 0)) && (10点量比 > 1));
DK1:=(TJ5 && (C10 > (昨收 + 半缺)));
DK2:=(TJ5 && (C10 = (昨收 + 半缺)));
DK3:=(TJ5 && (C10 < (昨收 + 半缺)));
收阳:=((时间 >= 30) && (((((PK1 || GK1) || GK4) || GK7) || DK1) || GK0));
收平:=((时间 >= 30) && ((((PK2 || GK2) || GK5) || GK8) || DK2));
收阴:=((时间 >= 30) && ((((PK3 || GK3) || GK6) || GK9) || DK3));
低开最佳:=((变盘 && (今开 < 昨收)) && (C10 > 昨收));
洗盘盘口:=(((变盘 && (今开 < 昨收)) && (C10 <= 今开)) && (H10 >= 昨收));
低开弱势:=(((变盘 && (今开 < C10)) && (C10 <= 昨收)) && (H10 >= 昨收));
平开最佳:=((变盘 && (今开 = 昨收)) && (C10 < 昨收));
平开跳水:=(((变盘 && (今开 = 昨收)) && (C10 > 今开)) && (L10 <= 昨收));
平开弱势:=(((变盘 && (今开 = 昨收)) && (C10 = 今开)) && (L10 <= 昨收));
高开最佳:=((变盘 && (今开 > 昨收)) && (C10 < 昨收));
高开跳水:=(((变盘 && (今开 > 昨收)) && (C10 > 今开)) && (L10 <= 昨收));
高开弱势:=(((变盘 && (今开 >= C10)) && (C10 >= 昨收)) && (L10 <= 昨收));



N:=区间;
H1:=(昨收 + ((H10 - L10) * N));H11:=H1-(H10 - L10);
L1:=(昨收 - ((H10 - L10) * N));L11:=L1+(H10 - L10);
H2:=(今开 + ((H10 - L10) * N));H22:=H2-(H10 - L10);
L2:=(今开 - ((H10 - L10) * N));L22:=L2+(H10 - L10);
H3:=(L10 + ((昨收 - L10) * N));H33:=H3-(昨收 - L10);
L3:=(L10 - ((昨收 - L10) * N));L33:=L3+(昨收 - L10);
H4:=(H10 + ((H10 - L10) * N));H44:=H4-(H10 - L10);
L4:=(H10 - ((H10 - L10) * N));L44:=L4+(H10 - L10);
H5:=(昨收 + ((今开 - L10) * N));H55:=H5-(今开 - L10);
L5:=(昨收 - ((今开 - L10) * N));L55:=L5+(今开 - L10);
计算前提:=((10点量比 > 1) || (变盘 = 1));
D1:=((计算前提 && (今开 < 昨收)) && (C10 > 昨收));
D2:=(((计算前提 && (今开 < 昨收)) && (C10 <= 昨收)) && (C10 > 今开));
D3:=((计算前提 && (今开 < 昨收)) && (C10 <= 今开));
P1:=((计算前提 && (今开 = 昨收)) && (C10 > 昨收));
P2:=((计算前提 && (今开 = 昨收)) && (C10 = 昨收));
P3:=((计算前提 && (今开 = 昨收)) && (C10 < 昨收));
G1:=((计算前提 && (今开 > 昨收)) && (C10 > 今开));
G2:=(((计算前提 && (今开 > 昨收)) && (C10 > 昨收)) && (C10 <= 今开));
G3:=((计算前提 && (今开 > 昨收)) && (C10 <= 昨收));
今日高抛区间:IF(((D1 || P1) || P2),H1,IF(D2,H2,IF(((D3 || P3) || G3),H3,IF(G1,H4,IF(G2,H5,0))))),COLORgreen;
IF(((D1 || P1) || P2),H11,IF(D2,H22,IF(((D3 || P3) || G3),H33,IF(G1,H44,IF(G2,H55,0))))),COLORgreen;
  今日低吸区间:IF(((D1 || P1) || P2),L1,IF(D2,L2,IF(((D3 || P3) || G3),L3,IF(G1,L4,IF(G2,L5,0))))),COLORred;
IF(((D1 || P1) || P2),L11,IF(D2,L22,IF(((D3 || P3) || G3),L33,IF(G1,L44,IF(G2,L55,0))))),COLORred;



SJ:=(TIME >= 100000);

10收:=INTPART(REF(C,BARSLAST((TIME = 100000))));
10高:=INTPART(REF(HHV(C,0),BARSLAST((TIME <= 100000))));
10低:=INTPART(REF(LLV(C,0),BARSLAST((TIME <= 100000))));
今开1:=DYNAINFO(4);
昨收1:=DYNAINFO(3);
10收1:=REF(C,BARSLAST((TIME = 100000)));
10高1:=REF(HHV(C,0),BARSLAST((TIME <= 100000)));
10低1:=REF(LLV(C,0),BARSLAST((TIME <= 100000)));
HB:=(((今开1 < 昨收1) && (10高1 >= 昨收1)) || ((今开1 > 昨收1) && (10低1 <= 昨收1)));
WQ:=(今开1 = 昨收1);
XZ:=IF((白线在上 = 0),1,0);
ZJ:=(((((((今开 > 昨收) && (10收 < 昨收)) && (10收 < 今开)) || (((今开 < 昨收) && (10收 > 昨收)) && (10收 > 今开))) || ((今开 = 昨收) && ((10收 + 3) < 昨收))) && XZ) && SJ);
FX:=(((((今开 = 昨收) && (10收 > 昨收)) && (10收 > 今开)) || (((今开 > 昨收) && (10收 > 昨收)) && (10收 > 今开))) && SJ);
XP:=((((今开 < 昨收) && (10收 < 昨收)) && (10收 < 今开)) && SJ);
RS:=((((((今开 < 昨收) && (10收 <= 昨收)) && (10收 >= 今开)) || (((今开 > 昨收) && (10收 >= 昨收)) && (10收 <= 今开))) || (((今开 = 昨收) && (10收 = 昨收)) && (10收 = 今开))) && SJ);
STKNAME,COLORWHITE;
TD1:=(C > REF(C,4));
TD2:=LAST(TD1);
TD3:=(TD2 = 9);
TD4:=(TD3 && BETWEEN(TD2,5,8));
TD5:=((BACKSET((TD3 > 0),9) || BACKSET((TD4 > 0),TD2)) * TD2);
TD6:=(C < REF(C,4));
TD7:=LAST(TD6);
TD8:=(TD7 = 9);
TD9:=(TD8 && BETWEEN(TD7,5,8));
TD10:=((BACKSET((TD8 > 0),9) || BACKSET((TD9 > 0),TD7)) * TD7);

DRAWTEXTABS(1,5,'  开盘情况:'),COLORRED;
DRAWTEXTABS(1,20,'  缺口情况:'),COLORRED;
DRAWTEXTABS(136,5,'  强弱情况:'),COLORRED;
DRAWTEXTABS(136,20,'  综合情况:'),COLORRED;
DRAWTEXTABS(410,5,'  操盘建议:'),COLORRED;
DRAWTEXTABS(76,5,IFS(((((今开 > 昨收) && (10收 > 昨收)) && (10收 > 今开)) && SJ),'高开风险','')),COLORYELLOW;
DRAWTEXTABS(76,5,IFS(((((今开 > 昨收) && (10收 >= 昨收)) && (10收 <= 今开)) && SJ),'高开弱势','')),COLORYELLOW;
DRAWTEXTABS(76,5,IFS(((((今开 > 昨收) && (10收 < 昨收)) && (10收 < 今开)) && SJ),'高开强势','')),COLORYELLOW;
DRAWTEXTABS(76,5,IFS(((((今开 = 昨收) && (10收 = 昨收)) && (10收 = 今开)) && SJ),'平开弱势','')),COLORYELLOW;
DRAWTEXTABS(76,5,IFS(((((今开 = 昨收) && (10收 < 昨收)) && (10收 < 今开)) && SJ),'平开强势','')),COLORYELLOW;
DRAWTEXTABS(76,5,IFS(((((今开 = 昨收) && (10收 > 昨收)) && (10收 > 今开)) && SJ),'平开风险','')),COLORYELLOW;
DRAWTEXTABS(76,5,IFS(((((今开 < 昨收) && (10收 > 昨收)) && (10收 > 今开)) && SJ),'低开强势','')),COLORYELLOW;
DRAWTEXTABS(76,5,IFS(((((今开 < 昨收) && (10收 <= 昨收)) && (10收 >= 今开)) && SJ),'低开弱势','')),COLORYELLOW;
DRAWTEXTABS(76,5,IFS(((((今开 < 昨收) && (10收 < 昨收)) && (10收 < 今开)) && SJ),'低开洗盘','')),COLORYELLOW;
DRAWTEXTABS(76,20,IFS(SJ,IFS(HB,'缺口已补',IFS((WQ && SJ),'今日无缺','缺口未补')),'')),COLORYELLOW;
DRAWTEXTABS(210,5,IFS(SJ,IFS(白线在上,'大盘股强','小盘股强'),'')),COLORYELLOW;
DRAWTEXTABS(210,20,IFS(ZJ,'最佳盘口',IFS((XP && HB),'洗盘买入','心中无底'))),COLORYELLOW;
DRAWTEXTABS(480,5,IFS(FX,'午盘量够就横盘,否则下跌概率大,当日不跌次日跌。','')),COLORYELLOW;
DRAWTEXTABS(480,5,IFS((XP && (HB = 0)),'假若缺口不回补,洗盘不知何时了,盘中看紧小双手。',IFS((XP && HB),'当日缺口已回补,放量阴线是最佳,来日上涨概率大。',' '))),COLORYELLOW;
DRAWTEXTABS(480,5,IFS(ZJ,'回调支撑位布局,当天收益概率大,低吸高抛甚是爽。','')),COLORYELLOW;
DRAWTEXTABS(480,5,IFS((RS && (HB = 0)),'假若缺口不回补,盘中看紧小双手,要防明日走低开。',IFS((RS && HB),'当日缺口已回补,盘中看紧小双手,要防明日低开走。',''))),COLORYELLOW;

本帖寻求各位老师的解答

回复被采纳后将获得奖励 共享币 5 个 ,目前已有 9 个回复 我来解答

附件

1.png
2.png

举报

使用道具 扔鸡蛋 回复

飞向热点
Lv.3
发表于 2021-12-1 11:03 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

飞向热点
Lv.3
发表于 2021-11-29 18:20 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

飞向热点
Lv.3
发表于 2021-11-26 19:33 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

飞向热点
Lv.3
发表于 2021-11-26 07:11 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

飞向热点
Lv.3
发表于 2021-11-25 21:19 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

飞向热点
Lv.3
发表于 2021-11-25 17:41 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

秋天的童话吧
Lv.1
发表于 2021-11-25 17:22 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

飞燕哥哥
Lv.1
发表于 2021-11-25 16:22 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

飞向热点
Lv.3
发表于 2021-11-25 14:04 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表