请教指导编写选股指标

[通达信]
设置
1982 2 红花绿叶配 Lv.2 发表于 · 2021-11-25 17:34 显示全部楼层 正序浏览 |
跳转到指定楼层
本帖最后由 红花绿叶配 于 2021-11-25 17:39 编辑

强弱分界:EMA(COST(85),10){,PRECISION2,LINEDOT},COLORRED,DOTLINE;

分界:EMA(COST(99),10){,PRECISION2,LINEDOT},COLORGREEN,DOTLINE;
DRAWBAND(强弱分界,RGB(80,00,20),
分界,RGB(80,60,18));


{缺口}
S1:=LOW>(REF(HIGH,1)+0.001);
S2:=BARSLAST(S1);
S3:=COUNT(L>REF(H,S2+1),S2+1)=S2+1;
S4:=CROSS(BACKSET(S3>0 AND ISLASTBAR,S2+1),0.5);
S5:=BARSLAST(S4);
上:IF(CURRBARSCOUNT<=CONST(S5+1),CONST(LLV(L,S5+1)),DRAWNULL),COLORGRAY;
下:IF(CURRBARSCOUNT<=CONST(S5+1),REF(H,S5+1),DRAWNULL),COLORGRAY;
STICKLINE( CURRBARSCOUNT<=CONST(S5+1),上,下,5,0),COLORGRAY;
DRAWKLINE(H,O,L,C);
MV10:=MA(V,10);
AVG_V:=(V-MV10)/MV10*100;
量差:=AVG_V-REF(AVG_V,1);
假阴:=C>REF(C,1) AND C<O;
高开:=(O-REF(C,1))/REF(C,1)*100;
倍量:=V>REF(V,1)*1.69 AND V>REF(HHV(V,20),1);
振幅:=(H-L)/REF(C,1)*100;
ZF:=(C-REF(C,1))/REF(C,1)*100;
涨停:=C/REF(C,1)>1.06  ;
三元:=EVERY(涨停,3) OR EVERY(涨停,2);
XG1:=REF(三元,1) AND 倍量;
XG2:=三元 AND 倍量;
XG0610:=三元 AND 量差>REF(HHV(量差,20),1);
XG2265:=REF(EVERY(涨停,2),1) AND 振幅>15 AND ZF>0.5 AND 倍量;
XG600352:=高开>=6 AND 假阴 AND REF(EVERY(涨停,2),1) AND 倍量;
XG3:=XG2 OR XG1 OR XG0610 OR XG2265 OR XG600352;
XGOK:=FILTER(XG3,2);

T:BARSLAST(XGOK),NODRAW;

Z1:=BARSLAST(CROSS(C,REF(C,T)));

PZ:=Z1>0 AND COUNT(MAX(C,O)>REF(C,T),Z1)=Z1 AND Z1<20 AND C/REF(C,1)>1.085;

PZ1:=FILTER(PZ>0,10);

PZ2:=FILTER(T>1 AND COUNT(MAX(C,O)>REF(C,T),T)=T AND T<20 AND C/REF(C,1)>1.085,10);

P3:=PZ1 OR PZ2;

DRAWICON(P3>0,L*0.98,23);

{量王}
总量:=AMOUNT,VOLSTICK;
量比:=V/REF(MA(V,5),1),COLORBROWN,NODRAW;
几倍:=1.9;
倍量量王:= 总量 >=REF(总量,1)*几倍 AND (IF(C<O,C>REF(C,1),1)),COLORYELLOW,NODRAW;

天量:=总量=HHV(总量,120), COLORRED;
量王:=天量&&倍量量王&&量比>2&&(BARSCOUNT(C)+1)>120,COLORGREEN;
STICKLINE(量王,C,O,0.1,0),COLORGREEN;
DRAWLINE(量王,H,REF(量王,1),REF(H,1),1),COLOR0066BB,LINETHICK1;
DRAWLINE(量王,L,REF(量王,1),REF(L,1),1),COLORGREEN;

涨幅:=(C-REF(C,1))/REF(C,1)*100;
梯量:=EVERY(C>O,3) AND  EVERY(C>REF(C,1),2) AND EVERY(V>REF(V,1),2) AND SUM(涨幅,3)<15;
DRAWTEXT(FILTER(梯量,2),H,'T3'),COLOR888888;
BK:=BARSLAST(CURRBARSCOUNT=CONST(BARSLAST(FILTER(梯量,2)))+1),LINETHICK1,COLORD355BA;
T3:REF(H,BK),LINETHICK1,COLORD355BA;



请教编写股价突破 上 的选股指标。

本帖寻求各位老师的解答

 闹海老龙神2021-11-25 18:58发表回复被红花绿叶配采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

附件

截图00.png

举报

使用道具 扔鸡蛋 回复

南风北往
Lv.3
发表于 2021-11-25 18:59 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 点亮 支持 扔鸡蛋 回复

闹海老龙神
Lv.5
发表于 2021-11-25 18:58 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表