大神看下这个副图指标能做成选股公式吗

[通达信]
设置
2156 12 我爱大A Lv.2 发表于 · 2021-11-25 19:41 显示全部楼层 正序浏览 |
跳转到指定楼层
要求我写在评论,请老师看下是否可以做个选股公式
DRAWGBK(OPEN>CLOSE,RGB(160,32,240),RGB(56,94,15),0,11,0);
X_1:=WINNER(CLOSE);
X_2:=VOL/CAPITAL;
轿夫:STICKLINE(X_1-X_2,X_1,X_2,1,(-1)),COLORRED;
X_3:=1;
X_4:=LLV(LOW,5);
X_5:=HHV(HIGH,5);
X_6:=SUM((CLOSE-REF(CLOSE,1))/REF(CLOSE,1),30);
X_7:=SUM((AMOUNT-REF(AMOUNT,1))/REF(AMOUNT,1)/(VOL*100)/CLOSE,30);
抬轿热情:STICKLINE(X_6>=X_7,X_6,0,1,0),COLORMAGENTA;
STICKLINE(X_6<X_7,X_6,0,1,0),COLORCYAN;
抬轿节奏:EMA((CLOSE-X_4)/(X_5-X_4)*100,4)*X_3/100,COLORWHITE;
X_8:=EMA(AMOUNT,5)/EMA(VOL,5)/100;
X_9:=EMA(AMOUNT,13)/EMA(VOL,13)/100;
X_10:=EMA(AMOUNT,34)/EMA(VOL,34)/100;
X_11:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
X_12:=HHV(HIGH,34)-LLV(X_10,34);
X_13:=HHV(HIGH,34)+LLV(X_10,34);
X_14:=EMA((X_12+X_13)/5,5);
X_15:=(CLOSE-EMA(X_14,17))/EMA(X_14,17)*100;
X_16:=EMA(X_15,34);
X_17:=MOD(X_16,X_15);
X_18:=HHV(HIGH,70);
X_19:=LLV(LOW,70);
X_20:=HHV(HIGH,20);
X_21:=LLV(LOW,20);
X_22:=X_18*(1-5/100);
X_23:=X_19*(1+5/100);
X_24:=X_20*(1-5/100);
X_25:=X_21*(1+5/100);
X_26:=MA(CLOSE,10);
硬轿:IF(ABS(X_16-X_17)<0.99,1,DRAWNULL),CIRCLEDOT,COLORWHITE,LINETHICK3;
软轿:IF(ABS(X_16-X_17)<=0.5 AND ABS(X_22-X_24)<=0.5,1,DRAWNULL),CIRCLEDOT,COLORYELLOW,LINETHICK3;
X_27:=WINNER(CLOSE)*CAPITAL/100;
X_28:=WINNER(CLOSE);
下坡:STICKLINE(X_27<=VOL/100 AND WINNER(CLOSE)<0.01,0,(-0.58),2,0),COLOR0088FF;
X_29:=HIGH-MIN(OPEN,CLOSE);
X_30:=CLOSE-OPEN;
X_31:=MAX(OPEN,CLOSE)-LOW;
X_32:=HIGH-LOW;
X_33:=VOL*X_29/X_32;
X_34:=VOL*X_30/X_32;
X_35:=VOL*X_31/X_32;
X_36:=X_33-X_34-X_35;
X_37:=SUM(X_36,20)/MA(VOL,20)/20;
X_38:=REVERSE(X_37);
X_39:=IF(X_38>X_37 AND X_38<=1.2,X_38,0);
X_40:=IF(X_38<X_37 AND X_38>=(-1.2),X_38,0);
X_41:=EMA(SLOPE(CLOSE,21)*20+CLOSE,55)*1;
X_42:=EMA(CLOSE,3);
STICKLINE(X_38>X_37,(-0.58),(-0.58)+X_39,2,0),COLORLIMAGENTA;
STICKLINE(X_38<X_37,0,0+X_40,2,0),COLORGREEN;
EMA(0.66*REF(抬轿节奏,1)+0.333*抬轿节奏,2)*X_3,COLORYELLOW;
IF(X_42>X_41,(-0.6),DRAWNULL),CIRCLEDOT,COLORRED;
IF(X_42<=X_41,(-0.6),DRAWNULL),CIRCLEDOT,COLORA53412;

本帖寻求各位老师的解答

 闹海老龙神2021-11-25 20:16发表回复被我爱大A采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

附件

d90a7c38cc6b62e49449deea4524b2b.png
本主题由 任务系统 于 2021-11-25 19:54 审核通过

举报

使用道具 扔鸡蛋 回复

我爱大A
Lv.2
发表于 2021-11-26 08:33 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 点亮 支持 扔鸡蛋 回复

博享受
Lv.1
发表于 2021-11-25 21:49 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

我爱大A
Lv.2
发表于 2021-11-25 21:32 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

博享受
Lv.1
发表于 2021-11-25 21:23 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南
查看全部打赏
  • 我爱大A+10理想币 : 感谢知识分享,感谢经验交流。

举报

使用道具 支持 扔鸡蛋 回复

我爱大A
Lv.2
发表于 2021-11-25 21:10 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

我爱大A
Lv.2
发表于 2021-11-25 21:06 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

虞城山湖
Lv.3
发表于 2021-11-25 20:56 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 点亮 支持 扔鸡蛋 回复

博享受
Lv.1
发表于 2021-11-25 20:34 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

博享受
Lv.1
发表于 2021-11-25 20:33 复制 查看全部楼层
本帖为密码帖 ,请输入密码 

举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

闹海老龙神
Lv.5
发表于 2021-11-25 20:16 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。

举报

使用道具 支持 (1) 扔鸡蛋 回复

博享受
Lv.1
发表于 2021-11-25 20:16 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

我爱大A
Lv.2
发表于 2021-11-25 19:45 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表