来位大佬把这个指标做个选股公式

[通达信]
设置
2472 4 雨露潇潇 Lv.2 发表于 · 2021-11-25 22:03 显示全部楼层 正序浏览 |
跳转到指定楼层

周、月、底、和紫色箭头标记,这些信号做个选股公式



DD11:0.9,COLORFF33FF;
DD22:1.2,COLORGREEN;
{黄金柱}
M:=30;
N:=15;
AJ:=HHV(H,M)=H;
AJT:=BARSLAST(AJ);
AJ1:=LLV(L,N)=L;
AJ1T:=BARSLAST(AJ1);
TJ:=HHV(H,M)=H;
TJT:BARSLAST(TJ)NODRAW;
TJ1T:=BARSLAST(AJ1);
{STICKLINE((TJT=0,H,TJ1T=0) AND AJ1 AND FILTERX(AJ1,TJT+1) ,REF(L,TJ1T)
,REF(H,TJT),0,0)COLORBLUE,LINETHICK3;}
OUT:=STICKLINE((TJT=0,H,TJ1T=0) AND AJ1 AND FILTERX(AJ1,TJT+1) ,REF(L,TJ1T)
,REF(H,TJT),0,0)COLORBLUE,LINETHICK3;
STICKLINE(OUT>0,0,0.89,4,0),COLORYELLOW,LINETHICK2;{黄色柱}
DRAWTEXT(OUT,0.95,'底'),COLORYELLOW;
{KDJ日金}
日K:="KDJ.K#DAY"(9,3,3);
日D:="KDJ.D#DAY"(9,3,3);
DRAWICON(日K>日D,0.1,32);
DRAWICON(日K<日D,0.1,2);
DRAWTEXT(ISLASTBAR=1,0.1,'日K');
{MACD日金}
日DIF:="MACD.DIF#DAY"(12,26,9);
日DEA:="MACD.DEA#DAY"(12,26,9);
DRAWICON(日DIF>日DEA,0.2.1,32);
DRAWICON(日DIF<日DEA,0.2,2);
DRAWTEXT(ISLASTBAR=1,0.2,'日M');
{RSI日}
日RSI:="RSI.RSI1#DAY"(9);
DRAWICON(日RSI>50,0.3,32);
DRAWICON(日RSI<50,0.3,2);
DRAWTEXT(ISLASTBAR=1,0.3,'日R');
{KDJ周金}
周K:="KDJ.K#WEEK"(9,3,3);
周D:="KDJ.D#WEEK"(9,3,3);
DRAWICON(周K>周D,0.4,13);
DRAWICON(周K<周D,0.4,2);
DRAWTEXT(ISLASTBAR=1,0.4,'周K');
{MACD周金}
周DIF:="MACD.DIF#WEEK"(12,26,9);
周DEA:="MACD.DEA#WEEK"(12,26,9);
DRAWICON(周DIF>周DEA,0.5,13);
DRAWICON(周DIF<周DEA,0.5,2);
DRAWTEXT(ISLASTBAR=1,0.5,'周M');
{RSI周}
周RSI:="RSI.RSI1#WEEK"(9);
DRAWICON(周RSI>50,0.6,13);
DRAWICON(周RSI<50,0.6,2);
DRAWTEXT(ISLASTBAR=1,0.6,'周R');
{KDJ月金}
月K:="KDJ.K#MONTH"(9,3,3);
月D:="KDJ.D#MONTH"(9,3,3);
DRAWICON(月K>月D,0.7,33);
DRAWICON(月K<月D,0.7,2);
DRAWTEXT(ISLASTBAR=1,0.7,'月K');
{MACD月金}
月DIF:="MACD.DIF#MONTH"(12,26,9);
月DEA:="MACD.DEA#MONTH"(12,26,9);
DRAWICON(月DIF>月DEA,0.8,33);
DRAWICON(月DIF<月DEA,0.8,2);
DRAWTEXT(ISLASTBAR=1,0.8,'月M');
{RSI月}
月RSI:="RSI.RSI1#MONTH"(9);
DRAWICON(月RSI>50,0.9,33);
DRAWICON(月RSI<50,0.9,2);
DRAWTEXT(ISLASTBAR=1,0.9,'月R');
X1:=日K>日D;
X2:=日DIF>日DEA;
X3:=日RSI>50;
X4:=周K>周D;
X5:=周DIF>周DEA;
X6:=周RSI>50;
X7:=月K>月D;
X8:=月DIF>月DEA;
X9:=月RSI>50;
黑马初显:=X1 AND X2 AND X3 AND X4 AND X5 AND X6 AND X7 AND X8 AND X9;
STICKLINE(黑马初显,0.05,0.91,0.12,0),COLORRED;
STICKLINE(黑马初显 AND C/REF(C,1)>1.095,0.05,0.91,0.66,0),COLORYELLOW;
STICKLINE(黑马初显 AND C/REF(C,1)>1.095,0.05,0.91,0.06,0),COLORRED;
月RSI1:="RSI.RSI1#MONTH"(9),COLORWHITE;
A:=月RSI1>50;
首月R:CROSS(A>REF(A,1),0.5),COLORWHITE,LINETHICK3;
STICKLINE(首月R,1.2,1.12,5,0),COLORWHITE,LINETHICK3;
DRAWTEXT(首月R,1.11,'&NBSP; --月共振'),COLORWHITE;
月DIF1:="MACD.DIF#MONTH"(12,26,9)COLORYELLOW;
月DEA1:="MACD.DEA#MONTH"(12,26,9)COLORYELLOW;
AA:=月DIF1>月DEA1;
首月M:CROSS(AA>REF(AA,1),0.5)COLORYELLOW;
STICKLINE(首月M,1.15,1.1,5,0),COLORYELLOW;
月K1:="KDJ.K#MONTH"(9,3,3),COLORMAGENTA;
月D1:="KDJ.D#MONTH"(9,3,3),COLORMAGENTA;
AAA:=月K1>月D1;
首月K:CROSS(AAA>REF(AAA,1),0.5),COLORMAGENTA,LINETHICK3;
STICKLINE(首月K,1.1,1.05,5,0),COLORMAGENTA,LINETHICK3;
周RSI1:="RSI.RSI1#WEEK"(9),COLORGREEN;
AAAA:=周RSI1>50;
首周R:CROSS(AAAA>REF(AAAA,1),0.5),COLORRED,LINETHICK4;
STICKLINE(首周R,1.05,1,5,0),COLORRED,LINETHICK4;
DRAWTEXT(首周R,1.03,' --周共振'),COLORRED;
周DIF1:="MACD.DIF#WEEK"(12,26,9),COLORCYAN;
周DEA1:="MACD.DEA#WEEK"(12,26,9),COLORCYAN;
AAAAA:=周DIF1>周DEA1;
首周M:CROSS(AAAAA>REF(AAAAA,1),0.5),COLORCYAN;
STICKLINE(首周M,1,0.95,5,0),COLORCYAN;
周K1:="KDJ.K#WEEK"(9,3,3),COLORBLUE;
周D1:="KDJ.D#WEEK"(9,3,3),COLORBLUE;
AAAAAA:=周K1>周D1;
首周K:CROSS(AAAAAA>REF(AAAAAA,1),0.5),COLORBLUE;
STICKLINE(首周K,1.05,1,0,0),COLORBLUE,LINETHICK1;
STICKLINE(首周K,0.95,0.91,5,0),COLORBLUE;
DRAWTEXT(首周K,0.935,' --黄金坑'),COLORYELLOW;
DRAWTEXT(黑马初显,0.935,'-飚'),COLORYELLOW;

本帖寻求各位老师的解答

 帝莫语2021-11-26 07:28发表回复被雨露潇潇采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

举报

使用道具 扔鸡蛋 回复

雨露潇潇
Lv.2
发表于 2021-11-26 15:27 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

帝莫语
Lv.2
发表于 2021-11-26 14:36 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

附件

未命名截图.png

举报

使用道具 点亮 支持 扔鸡蛋 回复

雨露潇潇
Lv.2
发表于 2021-11-26 13:06 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

附件

M(8}B_J3FO47Q}P0A$XYUEJ.png

举报

使用道具 支持 扔鸡蛋 回复

帝莫语
Lv.2
发表于 2021-11-26 07:28 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 关闭 上一条 /7 下一条
回顶部 到页底
快速回复 返回顶部 返回列表