最全公司基本面指标可与任何通达信主图叠加

[通达信]
设置
28659 46 3944166 Lv.2 发表于 · 2021-11-29 12:55 显示全部楼层 正序浏览 |
跳转到指定楼层
涨跌:=REF(C,1);

涨停:=IF((C-涨跌)*100/涨跌>=(10-0.01*100/涨跌),1,0);

STICKLINE(涨停,OPEN,CLOSE,2,0),COLORRED;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((涨跌-C)*100/涨跌>=(10-0.01*100/涨跌),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLOR808000;

换手:HSL.HSL,NODRAW;
成交量:VOL/10000,NODRAW;


昨日成交额:REF(AMOUNT/100000000,1),NODRAW;{亿元}
今日成交额:AMOUNT/100000000,NODRAW;


ZTCS:=COUNT(涨停,BARSLAST(涨停+1));

DRAWTEXT_FIX(FINANCE(3)=3||FINANCE(3)=4,0,0.37,0,STRCAT('涨停价: ',VAR2STR(ZTPRICE(REF(C,1),0.2),2)));
DRAWTEXT_FIX(FINANCE(3)=3||FINANCE(3)=4,0,0.42,0,STRCAT('跌停价: ',VAR2STR(DTPRICE(REF(C,1),0.2),2)));
DRAWTEXT_FIX(FINANCE(3)=1||FINANCE(3)=2,0,0.37,0,STRCAT('涨停价: ',VAR2STR(ZTPRICE(REF(C,1),0.1),2)));
DRAWTEXT_FIX(FINANCE(3)=1||FINANCE(3)=2,0,0.42,0,STRCAT('跌停价: ',VAR2STR(DTPRICE(REF(C,1),0.1),2)));
开盘价:OPEN,NODRAW;
最高价:HIGH,NODRAW;
最低价:LOW,NODRAW;





板块上涨家:HY_INDEXADV,NODRAW;
板块下跌家:HY_INDEXDEC,NODRAW;
{涨跌停家数}
涨停数:"880006$C",NODRAW;
跌停数:"880006$O",NODRAW;





GZT1:=STRCAT(' 共涨停: ',CON2STR(ZTCS,0));
GZT2:=STRCAT(GZT1,'次');
SSTS1:=STRCAT(' 上市: ',CON2STR(FINANCE(42),0));
SSTS2:=STRCAT(SSTS1,'天');
NTZZT1:=STRCAT(' 距今:',CON2STR(CONST(BARSLAST(涨停)),0));
NTZZT2:=STRCAT(NTZZT1,'天有涨停');
ZTTJ1:=STRCAT(SSTS2,GZT2);
ZTTJ2:=STRCAT(ZTTJ1,NTZZT2);
ZTTJ:=STRCAT('涨停统计:',ZTTJ2);
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.33,0,ZTTJ),COLORYELLOW;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(涨停)),REF(HIGH,BARSLAST(涨停)),0.1,0),COLORDDDD00;
STICKLINE(CLOSE,REF(LOW,BARSLAST(涨停)),REF(LOW,BARSLAST(涨停)),0.1,0),COLOR00DDDD;





竞价额:=DYNAINFO(15)/10000;{万元}

DRAWTEXT_FIX(C>0,0.00,0.46,0,VARCAT(VARCAT('竞价: ',VAR2STR(竞价额,0)),' 万')),
COLORMAGENTA;



CJE:=VOL*C/100,NODRAW;

主题1:=STRCAT('【主题投资】:',EXTERNSTR(0,1));

主营1:=STRCAT('【主营业务】:',EXTERNSTR(0,2));

主题和主营1:=STRCAT(主营1,'   ■■   ');
主题和主营2:=STRCAT(主题和主营1,主题1);
主题和主营3:=STRCAT(STRCAT(STRCAT(STRCAT('【行业信息】:',HYBLOCK),'   ■■   '),主题和主营2),'');



DRAWTEXT_FIX(1,0.95,0.98,1,主题和主营3),COLOR00FFFF;  

TJ:=ISLASTBAR AND C<500;
DRAWTEXT_FIX(TJ,0.005,0.04,0,FGBLOCK),COLORGREEN;


所属板块:=STRCAT('所属板块: ',STRCAT(STRCAT(STRCAT('[行业]-',HYBLOCK),STRCAT(' [地域]-',DYBLOCK)),STRCAT(' [概念]-',GNBLOCK)));


主收同比:=STRCAT(' 主收同比: ',CON2STR(FINANCE(44),2));
市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利润率: ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
现金流:=STRCAT(' 现金流: ',CON2STR(FINANCE(25)/FINANCE(1),2));
利润同比:=STRCAT(' 利润同比: ',CON2STR(FINANCE(43),2));
DRAWTEXT_FIX(ISLASTBAR,0.003,0.11,0,市盈率);
DRAWTEXT_FIX(ISLASTBAR,0,0.14,0,市销率);
DRAWTEXT_FIX(ISLASTBAR,0,0.17,0,市净率);
DRAWTEXT_FIX(ISLASTBAR,0,0.21,0,毛利率);
DRAWTEXT_FIX(ISLASTBAR,0.1,0.21,0,现金流);
DRAWTEXT_FIX(ISLASTBAR,0.1,0.11,0,主收同比);
DRAWTEXT_FIX(ISLASTBAR,0.1,0.14,0,净利润率);
DRAWTEXT_FIX(ISLASTBAR,0.1,0.17,0,利润同比);
{业绩}
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(29)/FINANCE(19)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(净资收益率,毛利率),主营利润率));
{主图显示}
DRAWTEXT_FIX(ISLASTBAR,0.005,0.00,0,所属板块),COLOR00C0C0;

DRAWTEXT_FIX(ISLASTBAR,0.005,0.07,0,当前业绩),COLOR00C0C0;

总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100;
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=(流入-流出);
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入,3);
流出3:=SUM(流出,3);
净流3:=SUM(流入-流出,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入,5);
流出5:=SUM(流出,5);
净流5:=SUM(流入-流出,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入,10);
流出10:=SUM(流出,10);
净流10:=SUM(流入-流出,10);
画:=CONST(FINDHIGH(总额10,0,190,1));
DRAWTEXT_FIX(1,0.71,0.07,0,'净流(亿):'),COLOR8080FF,COLORWHITE;
DRAWTEXT_FIX(1,0.78,0.05,0,'1日'),COLOR8080FF,COLORWHITE;
DRAWTEXT_FIX(1,0.83,0.05,0,'3日'),COLOR8080FF,COLORWHITE;
DRAWTEXT_FIX(1,0.88,0.05,0,'5日'),COLOR8080FF,COLORWHITE;
DRAWTEXT_FIX(1,0.93,0.05,0,'10日'),COLOR8080FF,COLORWHITE;
DRAWNUMBER_FIX(1,0.78,0.10,0,CONST((净流))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.83,0.10,0,CONST((净流3))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.88,0.10,0,CONST((净流5))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.93,0.10,0,CONST((净流10))),COLORYELLOW;
股东人数:=FINANCE(8);
人均持股:=ROUND(FINANCE(7)/FINANCE(8));
DRAWTEXT_FIX(1,0.05,0.24,1,'股东人数:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.05,0.28,1,'人均持股:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.08,0.24,1,股东人数),COLORWHITE;
DRAWNUMBER_FIX(1,0.08,0.28,1,人均持股),COLORWHITE;
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替}
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
DRAWTEXT_FIX(1,0.85,0.01,1,'财务预警:'),COLORRED;
DRAWTEXT_FIX(Z值<1.2,0.838,0.11,1,' ●重 警●'),COLORLIRED;
DRAWTEXT_FIX( BETWEEN(Z值,1.2,2.6),0.838,0.11,1,' ○轻 警○'),COLOR0099FF;
DRAWTEXT_FIX(Z值>2.6,0.838,0.11,1,' ◎无 警◎'),COLORLIGREEN;


fakename.png

fakename.png

查看全部打赏
  • 杨大姐+20理想币 : 谢老师不求名不求利,点赞!!
本主题由 任务系统 于 2021-11-29 13:16 合并

举报

使用道具 扔鸡蛋 回复

3944166
Lv.2
发表于 2021-12-5 21:36 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 点亮 支持 扔鸡蛋 回复

3629248
Lv.2
发表于 2021-12-5 21:05 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3944166
Lv.2
发表于 2021-12-5 20:52 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3946835
Lv.2
发表于 2021-12-5 13:40 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3946835
Lv.2
发表于 2021-12-5 13:40 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3946835
Lv.2
发表于 2021-12-5 13:39 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3946835
Lv.2
发表于 2021-12-5 13:37 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3935015
Lv.1
发表于 2021-12-4 12:24 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3944166
Lv.2
发表于 2021-12-2 21:42 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3944166
Lv.2
发表于 2021-12-2 21:41 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 点亮 支持 扔鸡蛋 回复

3946835
Lv.2
发表于 2021-12-2 21:17 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3946835
Lv.2
发表于 2021-12-2 21:16 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3810841
Lv.1
发表于 2021-12-2 19:05 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

13400
Lv.3
发表于 2021-12-2 15:48 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

2044797
Lv.5
发表于 2021-12-2 08:55 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 点亮 支持 扔鸡蛋 回复

3732760
Lv.2
发表于 2021-12-2 01:21 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3956858
Lv.1
发表于 2021-12-1 11:28 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

2394185
Lv.2
发表于 2021-12-1 10:39 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3944166
Lv.2
发表于 2021-12-1 08:21 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 点亮 支持 (1) 扔鸡蛋 回复

3942870
Lv.2
发表于 2021-12-1 03:02 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

113480
Lv.2
发表于 2021-12-1 00:41 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

2291505
Lv.2
发表于 2021-11-30 22:17 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 点亮 支持 扔鸡蛋 回复

3037221
Lv.4
发表于 2021-11-30 21:08 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

1067632
Lv.3
发表于 2021-11-30 09:08 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3943453
Lv.2
发表于 2021-11-29 23:19 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

2805281
Lv.3
发表于 2021-11-29 19:29 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

2880248
Lv.3
发表于 2021-11-29 19:12 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3944166
Lv.2
发表于 2021-11-29 18:39 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...
查看全部打赏
  • 风铃111+10理想币 : 每天进步一点点,希望的火苗不熄灭。

举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

3944166
Lv.2
发表于 2021-11-29 18:38 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3944166
Lv.2
发表于 2021-11-29 18:38 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼 29楼
46楼 28楼
45楼 27楼
44楼 26楼
43楼 25楼
42楼 24楼
41楼 23楼
40楼 22楼
39楼 21楼
38楼 20楼
37楼 19楼
36楼 18楼
35楼 17楼
34楼  
33楼  
32楼  
31楼  
30楼  
站长推荐 关闭 上一条 /8 下一条
回顶部 到页底
快速回复 返回顶部 返回列表