请老师作KK金叉DD的选股公式

[通达信]
设置
3148 4 2668083 Lv.2 发表于 · 2021-12-4 02:18 显示全部楼层 正序浏览 |
跳转到指定楼层
本帖最后由 农大发 于 2021-12-4 03:09 编辑

RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
J0:=(HIGH+LOW)/2;QJ:=EMA(J0,3);
J1:=IF(CLOSE>QJ,VOL,0);
J2:=IF(CLOSE<QJ,VOL,0);
量能:IF(CAPITAL<1,MA(VOL,74),MA(SUM(J1-J2,22),3)),COLOR00DDDD,NODRAW;
趋势:IF(CAPITAL<1,EMA(量能,360),EMA(量能,21)),COLOR008800,NODRAW;
VAR3:=(量能-趋势);
VAR44:=SMA(RV,3,1);
VAR55:=SMA(VAR44,3,1);
STICKLINE(VAR3>0,20,10,5,1),COLOR0000FF;
STICKLINE(VAR3<0,100,90,10,1),COLOR00FF00;
DRAWICON(CROSS(VAR44,VAR55) AND VAR55<30,2,1);
DRAWICON(CROSS(VAR55,VAR44) AND VAR55>30,97,2);
DRAWBAND(VAR55,RGB(0,22,224),VAR44,RGB(255,50,50));
KK:EMA(SMA(RG,3,1),2),COLORFFFFFF;DD:SMA(KK,3,1),COLOR00FFFF;
DRAWTEXT(CROSS(VAR44,VAR55) AND CROSS(KK,DD),10,'共振'),COLOR00FFFF;
共振点:=(CROSS(VAR44,VAR55) AND CROSS(KK,DD));
STICKLINE(共振点>0,0,100,2,0),COLOR008888;
STICKLINE(共振点>0,0,100,1.5,0),COLOR00AAAA;
STICKLINE(共振点>0,0,100,0.8,0),COLOR00DDDD;
STICKLINE(共振点>0,0,100,0.3,0),COLOR00FFFF;
VAR1:=1;
VAR2:=((((2*CLOSE)+HIGH)+LOW) / 4);
低金叉进:20,COLORFF00FF,LINETHICK2;
高死叉出:90,COLORBLUE,LINETHICK2;
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
C1:=(EMA((((VAR2-VAR4)/(VAR5-VAR4))*100),4)*VAR1),COLORFF00FF,LINETHICK2;
C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR1),COLORFFFFFF,LINETHICK2;
条件:=CROSS(C1,C2) AND C1<40;
条件0:=CROSS(C2,C1) AND C1>90;
TJ1:=CROSS(C1,C2);
TJ2:=CROSS(C2,C1);
TJ3:=CROSS(C1,C2) AND REF(C1,1)<20;
TJ4:=CROSS(C2,C1) AND REF(C1,1)>80;
DRAWTEXT(FILTER((REF(条件,1) AND (REF(LOW,1)>LOW OR TJ2))
OR (REF(条件,2) AND (REF(LOW,2)>LLV(LOW,3) OR TJ2))
OR (REF(条件,3) AND (REF(LOW,3)>LLV(LOW,4) OR TJ2)),4),70,'止'),COLORRED;
{DRAWTEXT(FILTER((REF(条件,1) AND (REF(LOW,1)>LOW OR TJ2))
OR (REF(条件,2) AND (REF(LOW,2)>LLV(LOW,3) OR TJ2))
OR (REF(条件,3) AND (REF(LOW,3)>LLV(LOW,4) OR TJ2)),4),60,'跌'),COLORRED;}
DRAWTEXT(FILTER((REF(条件,1) AND (REF(LOW,1)>LOW OR TJ2)) OR
(REF(条件,2) AND (REF(LOW,2)>LLV(LOW,3) OR TJ2))
OR (REF(条件,3) AND (REF(LOW,3)>LLV(LOW,4) OR TJ2)),4),65,'买'),COLORRED;
DRAWTEXT(条件,20,'买'),COLORRED;
STICKLINE(条件,0,20,2,0),COLORRED;
DRAWTEXT(条件0,85,'卖'),COLORBLUE;
DRAWTEXT(CROSS(C1,75),70,'险区'),COLORGREEN;
DRAWTEXT(TJ3,65,'安'),COLORRED;
DRAWTEXT(TJ3,60,'买'),COLORRED;
DRAWTEXT(TJ4,85,'逃顶'),COLORBLUE;
STICKLINE(TJ4,100,80,2,0),COLORGREEN;
VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
操盘:=3*VAR300-2*VAR400;
A1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;
STICKLINE(A1,30,0,4,0),COLOR770077;
STICKLINE(A1,30,0,3,0),COLOR990099;
STICKLINE(A1,30,0,2,0),COLORBB00BB;
STICKLINE(A1,30,0,1,0),COLORDD00DD;
STICKLINE(A1,30,0,0.3,0),COLORFF00FF;
DRAWTEXT(A1,36,'财神到'),COLORRED;


本帖寻求各位老师的解答

 万钧彩2021-12-4 06:16发表回复被农大发采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

举报

使用道具 扔鸡蛋 回复

3960596
Lv.0
发表于 2021-12-4 15:56 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

3960596
Lv.0
发表于 2021-12-4 15:55 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

1546616
Lv.5
发表于 2021-12-4 06:16 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

2819578
Lv.2
发表于 2021-12-4 06:16 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
5楼
4楼
3楼
2楼
站长推荐 关闭 上一条 /8 下一条
回顶部 到页底
快速回复 返回顶部 返回列表