恳请老师出手帮忙修改一下指标

[通达信] 2967 4
设置
3066050 Lv.2

专栏

发表于 2021-12-22 09:14 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORYELLOW;
马线:=MA(牛线,6),COLORGREEN;{智能辅助线}
MA60:MA(C,60),COLORYELLOW, LINETHICK2;
M120:=MA(CLOSE,120),COLORWHITE;
M250:=MA(CLOSE,250),COLORDDDDDD;
TY:=C;
TY2:=L;
A1:=REF(TY,10)=HHV(TY,2*10+1);
B1:=FILTER(A1,10);
C1:=BACKSET(B1,10+1);
HD:=FILTER(C1,10);
A2:=REF(TY2,10)=LLV(TY2,2*10+1);
B2:=FILTER(A2,10);
C2:=BACKSET(B2,10+1);
LD:=FILTER(C2,10);
前期高位:REF(C,BARSLAST(HD)),COLOR00FF00,POINTDOT;
STICKLINE(C,前期高位,前期高位,8,0),COLORRED;

前期低位:REF(L,BARSLAST(LD)),COLOR00FF00,POINTDOT;
STICKLINE(L,前期低位,前期低位,8,0),COLORBLUE;



选股:CROSS(C,前期高位),NODRAW;

STICKLINE(选股,OPEN,CLOSE,1,0),COLORYELLOW;
STICKLINE(选股,H,L,0,1),COLORYELLOW;
现价:CONST(C)DOTLINE,COLORGREEN;

{昨日半分位}

半分位:=(O+C)/2;
昨半分位:=REF(半分位,1);
STICKLINE(ISLASTBAR,昨半分位,昨半分位,10,0),COLORYELLOW;

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);
Z4:=STRCAT(Z3,' ');
DRAWTEXT_FIX(ISLASTBAR,0.45,0.99,0,STRCAT(Z4,GNBLOCK)),COLORGREEN;



{涨停跌停}
C2A:=REF(C,1),NODRAW;
涨停:=REF(C,1)*1.1-C<0.01 AND H=C,NODRAW;
STICKLINE(涨停,OPEN,CLOSE,1,0),COLORRED;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((C2A-C)*100/C2A>=(10-0.01*100/C2A) AND L=C,1,0),NODRAW;
STICKLINE(跌停,OPEN,CLOSE,1,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;






{N1:1,100,10;N2:1,100,10;DISP:=1,3,2}
N1:=10;N2:=10;DISP:=2;
K:=IF(PERIOD=5,1,{日}
IF(PERIOD=6,1,{周}
IF(PERIOD=7,1,{月}
IF(PERIOD=8,1,{多分钟}
IF(PERIOD=9,1,{多日}
IF(PERIOD=10,1,{季}
IF(PERIOD=11,2,{年}
IF(PERIOD=4,1,{60F}
IF(PERIOD=3,1,{30F}
IF(PERIOD=2,1,{15F}
IF(PERIOD=1,1{5F},1{1F})))))))))))/10;

P1:=PEAK(1,K*N1,1);
P2:=PEAK(1,K*N1,2);
WP1:=PEAKBARS(1,K*N1,1);
WP2:=PEAKBARS(1,K*N1,2);
T1:=TROUGH(2,K*N2,1);
T2:=TROUGH(2,K*N2,2);
WT1:=TROUGHBARS(2,K*N2,1);
WT2:=TROUGHBARS(2,K*N2,2);
TJ1:=P1>T1 AND P2>T2 ;
ZD:=MAX(T1,T2);
ZG:=MIN(P1,P2);
LL:=MIN(T1,T2);
HH:=MAX(P1,P2);
TJ2:=FILTER(ZG>ZD,2);
TJ3:=ZG=REF(ZG,BARSLAST(TJ2)) OR ZD=REF(ZD,BARSLAST(TJ2));
TJ4:=TJ1&&TJ2&&NOT(TJ3);
TJ5:=BETWEEN(ZD,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
TJ6:=BETWEEN(ZG,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
TJ7:=ZG>REF(ZG,REF(BARSLAST(TJ4),1))&&ZD<REF(ZD,REF(BARSLAST(TJ4),1));
TJ8:=TJ4&&NOT(TJ5 OR TJ6 OR TJ7);
ZSD:=IF(TJ8,ZD,DRAWNULL);
ZSG:=IF(TJ8,ZG,DRAWNULL);
ZSH:=IF(TJ8,HH,DRAWNULL);
ZSL:=IF(TJ8,LL,DRAWNULL);
STICKLINE(TJ8,ZSH,ZSL,0,-1),COLORMAGENTA;
STICKLINE(TJ8,ZSD,ZSG,IF(DISP=1,3,0),1),COLORMAGENTA;
DRAWTEXT(DISP=2,ZSH,'中枢'),COLORRED;

MA5:MA(CLOSE,20),COLORRED,LINETHICK2;判:IF(MA5<REF(MA5,1),MA5,DRAWNULL),COLORWHITE,LINETHICK2;

附图指标有时候会被压缩,请老师帮忙修改一下,谢谢

本帖寻求各位老师的解答

 闹海老龙神2021-12-22 09:33发表回复被张彪77采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

举报

使用道具 扔鸡蛋 回复

3066050
Lv.2

专栏

发表于 2021-12-22 10:19 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

1514188
Lv.5

专栏

发表于 2021-12-22 09:54 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

3066050
Lv.2

专栏

发表于 2021-12-22 09:48 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
点评
  • 闹海老龙神 2021-12-22 09:54
    没有发现被压缩的现象,另外建议放到主图上

举报

使用道具 点亮 (2) 支持 扔鸡蛋 回复

1514188
Lv.5

专栏

发表于 2021-12-22 09:33 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。

举报

使用道具 点亮 (4) 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
5楼
4楼
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表