请做个盘中预警公式,不胜感激

[通达信]
设置
2143 5 3907864 Lv.4 发表于 · 2022-1-14 20:22 显示全部楼层 正序浏览 |
跳转到指定楼层
(源码如下)
A股:CAPITAL/1000000,LINETHICK0,COLORWHITE;
实际量:VOL,LINETHICK0;
{VAR1:=DYNAINFO(17)*REF(MA(VOL,5),1);
VAR2:=DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT;
预测:=IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR2)/10000;
预测量:STICKLINE(IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VAR1,VAR2),VAR1,0,7,1),COLORGRAY;}
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),POINTDOT,COLORRED;
主卖:IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORGREEN;
换手率%:VOL/CAPITAL*100,POINTDOT,COLORWHITE;
STICKLINE(C>=REF(C,1) ,0,VOL,2.5,1),COLORRED;
STICKLINE(C<REF(C,1),0,VOL,2.5,1),COLORGREEN;
STICKLINE(主买>0,0,主买,2.5,0),COLORRED;
STICKLINE(主卖<0 ,0,主卖,2.5,0),COLORGREEN;
资金异动:VOL/MA(VOL,55)*100,COLORYELLOW;
STICKLINE(资金异动>100 ,0,VOL,0.6,0),COLORYELLOW;
MA5:MA(V,5),COLORWHITE;
MA13:MA(V,13),COLORRED;
DRAWTEXT(CROSS(MA5,MA13),(V *1.05),'★'),COLORYELLOW;


要求如图所示的做个选股器,是0上红柱体量是0下绿柱体量的1.2倍预警(前提是上方柱体边框只要红的不要绿的,同时带有黄色柱体)

本帖寻求各位老师的解答

回复被采纳后将获得奖励 共享币 5 个 ,目前已有 5 个回复 我来解答

附件

QQ图片20220114174551.png

举报

使用道具 扔鸡蛋 回复

1415682
Lv.3
发表于 2022-1-16 11:39 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3935909
Lv.2
发表于 2022-1-14 21:06 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 点亮 支持 扔鸡蛋 回复

3907864
Lv.4
发表于 2022-1-14 20:53 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 点亮 支持 扔鸡蛋 回复

3907864
Lv.4
发表于 2022-1-14 20:52 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 点亮 支持 扔鸡蛋 回复

1560537
Lv.3
发表于 2022-1-14 20:47 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...
点评
  • 股票天12022-1-14 20:53
    0上红柱体量是0下绿柱体量的1.2倍预警(前提是上方柱体边框只要红的不要绿的,同时带有黄色柱体)
  • 股票天12022-1-14 20:52
    错误句 : 主买:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
6楼
5楼
4楼
3楼
2楼
站长推荐 关闭 上一条 /8 下一条
回顶部 到页底
快速回复 返回顶部 返回列表