改成能用的选股吧选不出来,谢谢老师

[通达信]
设置
2055 6 3947820 Lv.2 发表于 · 2022-1-14 22:11 显示全部楼层 正序浏览 |
跳转到指定楼层
大机构:=100*(1-WINNER(CLOSE)),COLORRED,LINETHICK3;{输出大机构:100*(1-以收盘价计算的获利盘比例),画红色,线宽为3}
VAR2:=1/WINNER(CLOSE);{VAR2赋值:1/以收盘价计算的获利盘比例}
VAR3:=MA(CLOSE,13);{VAR3赋值:收盘价的13日简单移动平均}
VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);{VAR4赋值:100-(收盘价-VAR3)/VAR3*100的绝对值}
VAR5:=LLV(LOW,120);{VAR5赋值:120日内最低价的最低值}
VAR6:=HHV(HIGH,120);{VAR6赋值:120日内最高价的最高值}
VAR7:=(VAR6-VAR5)/100;
VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,10,1);
VARB:=3*VAR9-2*SMA(VAR9,10,1);
VARC:=100-VARB;
基金私募:= (100-VARA),COLORYELLOW,LINETHICK2;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
VAR21:=(HIGH+LOW+CLOSE)/3;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70));
VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0);
VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24);
Z:=STICKLINE(VAR20,0,80,5,0),LINETHICK4,COLORRED;



HJ_1:=IF(DATETODAY(DATE)<999999999,1,DRAWNULL);
HJ_2:=REF(LOW,1);
HJ_3:=IF(DATE<999999999,1,DRAWNULL);
HJ_4:=SMA(ABS(LOW-HJ_2),3,1)/SMA(MAX(LOW-HJ_2,0),3,1)*100;
HJ_5:=EMA(IF(CLOSE*1.2,HJ_4*10,HJ_4/10),3)*HJ_1;
HJ_6:=LLV(LOW,38);
HJ_7:=HHV(HJ_5,38)*HJ_1;
HJ_8:=IF(LLV(LOW,90),1,0)*HJ_3;
HJ_9:=EMA(IF(LOW<=HJ_6,(HJ_5+HJ_7*2)/2,0),3)/618*HJ_8*HJ_3;
HJ_10:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100;
拉升:=CROSS(HJ_10,(-24));



XG:DRAWTEXT(CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1,90,'超级主力建仓!') , COLORRED;
XG1:=拉升 AND XG;

本帖寻求各位老师的解答

 虞城山湖2022-1-14 22:25发表回复被盛世奥美采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

举报

使用道具 扔鸡蛋 回复

3947820
Lv.2
发表于 2022-1-15 13:40 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

2844452
Lv.3
发表于 2022-1-15 12:28 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 点亮 支持 扔鸡蛋 回复

3947820
Lv.2
发表于 2022-1-15 12:25 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 支持 扔鸡蛋 回复

3947820
Lv.2
发表于 2022-1-15 02:29 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...
点评
  • 虞城山湖2022-1-15 12:28
    大机构:=100*(1-WINNER(CLOSE)),COLORRED,LINETHICK3; VAR2:=1/WINNER(CLOSE); VAR3:=MA(CLOSE,13); VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100); VAR5:=LLV(LOW,120); VAR6:=HHV(HIGH,120); VAR7:=(VAR6-VAR5)/100

举报

使用道具 点亮 支持 扔鸡蛋 回复

2844452
Lv.3
发表于 2022-1-14 22:25 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。

举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

3958479
Lv.3
发表于 2022-1-14 22:22 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看这里...

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
7楼
6楼
5楼
4楼
3楼
2楼
站长推荐 关闭 上一条 /8 下一条
回顶部 到页底
快速回复 返回顶部 返回列表