麻烦老师用这两个指标做两个选股 当出现图片上第一个蓝色柱时两个指标各做一个选....

[通达信]
设置
2353 7 3904196 Lv.2 发表于 · 2022-1-15 11:25 显示全部楼层 正序浏览 |
跳转到指定楼层

N1:=50;
N2:=90;
N3:=40;
NNN:=STRCAT(CON2STR(YEAR,0),' 年 ');
YYY:=STRCAT(CON2STR(MONTH,0),' 月 ');
RRR:=STRCAT(CON2STR(DAY,0),' 日 ');
WWW:=STRCAT('星期',CON2STR(WEEKDAY,0));
SSS:=STRCAT(STRCAT(STRCAT(NNN,YYY), RRR),WWW);
DRAWTEXT_FIX(C>0,0.77,0,0,SSS);
DRAWTEXT_FIX(C>0,0.004,1,0,DYBLOCK),COLORYELLOW,LINETHICK2;
DRAWTEXT_FIX(C>0,0.06,1,0,HYBLOCK),COLORRED,LINETHICK2;
DRAWTEXT_FIX(C>0,0.12,1,0,GNBLOCK),COLORWHITE,LINETHICK2;

快量:(EMA(CLOSE,N1) - EMA(CLOSE,N2));
慢量:EMA(快量,N3),COLOR00FFFF;
MACD:=2*(快量-慢量);
资金线:=HHV(MACD,1)*0.98,LINETHICK1,COLORRED;
资金3日线:=HHV(MACD,3)*0.98,LINETHICK1;
资金5日线:=HHV(MACD,5)*0.98,COLORWHITE,LINETHICK1;
持股:=IF(资金线>=REF(资金线,1) AND 资金3日线>=资金线 AND 资金3日线>=REF(资金3日线,1) AND 资金3日线=资金5日线,1.5,0),COLORWHITE;
{DRAWICON(REF(持股<1.5,1) AND 持股,资金线,1);
DRAWICON(REF(资金线=资金5日线,1) AND 资金线<资金5日线,资金5日线,2);}
骑牛技术:0,COLORGRAY;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3,0),COLORRED;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,3,0),COLOR008080;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,3,0),COLOR00FF00;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,3,0),COLORFFFFFF;

STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,3,0 ),COLORFFAA00;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,3.3 ,0 ),COLORFFBB11;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,2.2,0 ),COLORFFCC22;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,1.65 ,0 ),COLORFFDD33;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,1.1 ,0 ),COLORFFEE44;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.55 ,0 ),COLORFFFF55;

STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,0,0 ),COLOR00E600;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,3.5,0 ),COLOR007700;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,2.7,0 ),COLOR008E00;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,2.1,0 ),COLOR009900;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,1.5,0 ),COLOR00B500;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,0.9,0 ),COLOR00D500;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,0.3,0 ),COLOR00E600;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,0,1 ),COLOR00E600;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,3.5,0),COLOR0044AA;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,3.4,0),COLOR0055AA;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,3.2,0),COLOR0066BB;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,3.0,0),COLOR0077BB;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,2.7,0),COLOR0088CC;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,2.4,0),COLOR0099CC;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,2.1,0),COLOR00AADD;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,1.8,0),COLOR00BBDD;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,1.4,0),COLOR00CCEE;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,1.0,0),COLOR00DDEE;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,0.6,0),COLOR00EEEE;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,0.2,0),COLOR00F0F3;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,0.05,0),COLOR00F6F3;

STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.5,0) ,COLOR00005A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.4,0) ,COLOR00006A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.3,0) ,COLOR00007A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.2,0) ,COLOR00008A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.1,0) ,COLOR00009A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.8,0) ,COLOR0000AA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.5,0) ,COLOR0000BA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.1,0) ,COLOR0000CA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,1.7,0) ,COLOR0000DA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,1.2,0) ,COLOR0000EA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.7,0) ,COLOR0000F5;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.2,0) ,COLOR0000FC;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.05,0),COLOR0000FF;

A:=BARSLAST(FILTERX(MACD=HHV(MACD,BARSLAST(MACD<0)),BARSLAST(MACD<0)));
B:=REF(MACD,A);
STICKLINE(A,B*1.05,B,4,0);
A1:=BARSLAST(FILTERX(MACD=LLV(MACD,BARSLAST(MACD>0)),BARSLAST(MACD>0)));
B1:=REF(MACD,A1);
STICKLINE(A1,B1*1.1,B1,4,2);









NNN:=STRCAT(CON2STR(YEAR,0),' 年 ');
YYY:=STRCAT(CON2STR(MONTH,0),' 月 ');
RRR:=STRCAT(CON2STR(DAY,0),' 日 ');
WWW:=STRCAT('星期',CON2STR(WEEKDAY,0));
SSS:=STRCAT(STRCAT(STRCAT(NNN,YYY), RRR),WWW);
DRAWTEXT_FIX(C>0,0.77,0,0,SSS);
DRAWTEXT_FIX(C>0,0.004,1,0,DYBLOCK),COLORYELLOW,LINETHICK2;
DRAWTEXT_FIX(C>0,0.06,1,0,HYBLOCK),COLORRED,LINETHICK2;
DRAWTEXT_FIX(C>0,0.12,1,0,GNBLOCK),COLORWHITE,LINETHICK2;
DRAWTEXT_FIX(1,0.88,5,0,'~☆~腾讯课堂骑牛作品~☆~'),COLORYELLOW;
快量:(EMA(CLOSE,12) - EMA(CLOSE,26));
慢量:EMA(快量,9),COLOR00FFFF;
MACD:=2*(快量-慢量);
资金线:=HHV(MACD,1)*0.98,LINETHICK1,COLORRED;
资金3日线:=HHV(MACD,3)*0.98,LINETHICK1;
资金5日线:=HHV(MACD,5)*0.98,COLORWHITE,LINETHICK1;
持股:=IF(资金线>=REF(资金线,1) AND 资金3日线>=资金线 AND 资金3日线>=REF(资金3日线,1) AND 资金3日线=资金5日线,1.5,0),COLORWHITE;
{DRAWICON(REF(持股<1.5,1) AND 持股,资金线,1);
DRAWICON(REF(资金线=资金5日线,1) AND 资金线<资金5日线,资金5日线,2);}
骑牛技术:0,COLORGRAY;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3,0),COLORRED;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,3,0),COLOR008080;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,3,0),COLOR00FF00;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,3,0),COLORFFFFFF;

STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,3,0 ),COLORFFAA00;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,3.3 ,0 ),COLORFFBB11;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,2.2,0 ),COLORFFCC22;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,1.65 ,0 ),COLORFFDD33;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,1.1 ,0 ),COLORFFEE44;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.55 ,0 ),COLORFFFF55;

STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,0,0 ),COLOR00E600;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,3.5,0 ),COLOR007700;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,2.7,0 ),COLOR008E00;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,2.1,0 ),COLOR009900;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,1.5,0 ),COLOR00B500;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,0.9,0 ),COLOR00D500;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,0.3,0 ),COLOR00E600;
STICKLINE(MACD<0 AND MACD<=REF(MACD,1),MACD,0,0,1 ),COLOR00E600;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,3.5,0),COLOR0044AA;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,3.4,0),COLOR0055AA;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,3.2,0),COLOR0066BB;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,3.0,0),COLOR0077BB;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,2.7,0),COLOR0088CC;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,2.4,0),COLOR0099CC;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,2.1,0),COLOR00AADD;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,1.8,0),COLOR00BBDD;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,1.4,0),COLOR00CCEE;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,1.0,0),COLOR00DDEE;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,0.6,0),COLOR00EEEE;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,0.2,0),COLOR00F0F3;
STICKLINE(MACD>0 AND MACD<=REF(MACD,1),MACD,0,0.05,0),COLOR00F6F3;

STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.5,0) ,COLOR00005A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.4,0) ,COLOR00006A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.3,0) ,COLOR00007A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.2,0) ,COLOR00008A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3.1,0) ,COLOR00009A;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.8,0) ,COLOR0000AA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.5,0) ,COLOR0000BA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.1,0) ,COLOR0000CA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,1.7,0) ,COLOR0000DA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,1.2,0) ,COLOR0000EA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.7,0) ,COLOR0000F5;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.2,0) ,COLOR0000FC;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.05,0),COLOR0000FF;

A:=BARSLAST(FILTERX(MACD=HHV(MACD,BARSLAST(MACD<0)),BARSLAST(MACD<0)));
B:=REF(MACD,A);
STICKLINE(A,B*1.05,B,4,0);
A1:=BARSLAST(FILTERX(MACD=LLV(MACD,BARSLAST(MACD>0)),BARSLAST(MACD>0)));
B1:=REF(MACD,A1);
STICKLINE(A1,B1*1.1,B1,4,2);

本帖寻求各位老师的解答

 博享受2022-1-15 14:26发表回复被书的采纳,获得奖励 共享币 5

√ 本帖所提出的问题已经获得完美解决,详细答案请看这里 >>>

附件

QQ图片20220115111850.jpg
本主题由 任务系统 于 2022-1-15 12:12 审核通过

举报

使用道具 扔鸡蛋 回复

3904196
Lv.2
发表于 2022-1-16 00:32 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

3904196
Lv.2
发表于 2022-1-15 19:21 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

3904196
Lv.2
发表于 2022-1-15 19:20 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 支持 扔鸡蛋 回复

709449
Lv.2
发表于 2022-1-15 17:41 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南
查看全部打赏
  • 书的+10理想币 : 很给力,投资愉快,理想因你而精彩;

举报

使用道具 点亮 (1) 支持 扔鸡蛋 回复

3904196
Lv.2
发表于 2022-1-15 14:54 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 点亮 支持 扔鸡蛋 回复

3904196
Lv.2
发表于 2022-1-15 14:53 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南

举报

使用道具 点亮 支持 扔鸡蛋 回复

3900655
Lv.2
发表于 2022-1-15 14:26 复制 查看全部楼层
您好,游客,您的用户组(游客)无法查看回复内容,请登录论坛或者去相关版区学习升级之后才能查看。升级指南
√ 该回复已被采纳,向作者支付 2 个共享币可查看详细解答内容。

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
8楼
7楼
6楼
5楼
4楼
3楼
2楼
站长推荐 关闭 上一条 /8 下一条
回顶部 到页底
快速回复 返回顶部 返回列表