关于通达信公式显示突然变化的原因

[通达信] 6468 2
设置
3532840 Lv.2

专栏

发表于 2022-1-18 09:58 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
一直以来一直用这个《挖金子》的指标,源码如下
DRAWTEXT_FIX(ISLASTBAR ,0.11,0.01,1,'所属地域板块------------'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.16,0.01,1,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.11,0.06,1,'所属行业------------'),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR ,0.14,0.06,1,HYBLOCK),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR ,0.11,0.11,1,'所属概念------------'),COLORBLUE;
DRAWTEXT_FIX(ISLASTBAR ,0.24,0.11,1,GNBLOCK),COLORWHITE;
黄金线:EMA(C,18),COLORMAGENTA;
【有金矿】:=COUNT(CLOSE<黄金线,5)=4 AND CLOSE/黄金线>1.004 AND
CROSS(CLOSE,黄金线) AND 黄金线>=REF(黄金线,1),LINETHICK,COLORRED;
DRAWTEXT(【有金矿】,LOW*0.99,'↖【挖金子】'),COLORRED;
STICKLINE(【有金矿】,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(【有金矿】,OPEN,CLOSE,1.1,0),COLORFF00FF;
STICKLINE(【有金矿】,OPEN,CLOSE,0.001,0),COLORWHITE;
A:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=9.8/100;
STICKLINE(A,C,O,3,0),COLORYELLOW,LINETHICK2;
STICKLINE(A,H,L,0,0),COLORYELLOW,LINETHICK2;
STICKLINE(A AND CLOSE=OPEN AND HIGH=LOW,REF(CLOSE,1),H,0,0),COLORGREEN,LINETHICK1;
B:=(REF(CLOSE,1)-CLOSE)/CLOSE>=9.8/100;
STICKLINE(B,C,O,3,0),COLORWHITE,LINETHICK2;
STICKLINE(B,H,L,0,0),COLORWHITE,LINETHICK2;
STICKLINE(B AND CLOSE=OPEN AND HIGH=LOW,REF(CLOSE,1),H,0,0),COLORGREEN,LINETHICK1;
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1:=(EMA(VAR1,14)+EMA(VAR1,14)+EMA(VAR1,14)+EMA(VAR1,14))/4;
IF(A1>=REF(A1,1),A1,DRAWNULL),COLORLIRED;
IF(A1<=REF(A1,1),A1,DRAWNULL),COLORGREEN,LINETHICK1;
A2:=EMA(A1,3);
IF(A2>=REF(A2,1),A2,DRAWNULL),COLORLIRED,LINETHICK2;
IF(A2<=REF(A2,1),A2,DRAWNULL),COLORGREEN,LINETHICK2;
A3:=EMA(A2,4);
IF(A3>=REF(A3,1),A3,DRAWNULL),COLORLIRED;
IF(A3<=REF(A3,1),A3,DRAWNULL),COLORGREEN;
MA1:=EMA(CLOSE,4);
IF(MA1>=REF(MA1,1),MA1,DRAWNULL ),COLORC0C0C0,LINETHICK1;
IF(MA1<=REF(MA1,1),MA1,DRAWNULL ),COLORBLUE,LINETHICK1;
MA2:=EMA(CLOSE,5);
IF(MA2>=REF(MA2,1),MA2,DRAWNULL ),COLORC0C0C0,LINETHICK3;
IF(MA2<=REF(MA2,1),MA2,DRAWNULL ),COLORBLUE,LINETHICK3;
MA3:=EMA(CLOSE,6);
IF(MA3>=REF(MA3,1),MA3,DRAWNULL ),COLORC0C0C0,LINETHICK1;
IF(MA2<=REF(MA3,1),MA3,DRAWNULL ),COLORBLUE,LINETHICK1;
A55:=EMA(A1,18);
IF(A55>=REF(A55,1),A55,DRAWNULL),COLORRED,LINETHICK1;
IF(A55<=REF(A55,1),A55,DRAWNULL),COLORFF00FF,LINETHICK1;
A56:=EMA(A55,3);
IF(A56>=REF(A56,1),A56,DRAWNULL),COLORRED,LINETHICK3;
IF(A56<=REF(A56,1),A56,DRAWNULL),COLORFF00FF,LINETHICK3;
A57:EMA(A55,5);
IF(A57>=REF(A57,1),A57,DRAWNULL),COLORRED,LINETHICK1;
IF(A57<=REF(A57,1),A57,DRAWNULL),COLORFF00FF,LINETHICK1;
STICKLINE(MA3>=A56 AND A56>=A2,A2,A56,4,0),COLORYELLOW;
STICKLINE(MA3>=A2 AND MA3<=A56,MA3,A2,4,0),COLORYELLOW;
DRAWTEXT(FILTER(MA3>=A2 AND MA3<=A56,10),L,'  ↖【黄金堆】'),COLORYELLOW;
STICKLINE(MA3<=A56 AND A56<=A2,A2,A56,4,0),COLORWHITE;
STICKLINE(MA3<=A2 AND MA3>=A56,MA3,A2,4,0),COLORWHITE;
DRAWTEXT(FILTER(MA3<=A2 AND MA3>=A56,5),H,'【瓦斯坑】'),COLORGREEN;
过均必牛:SUM(CLOSE*VOL,FROMOPEN)/SUM(VOL,FROMOPEN),COLORYELLOW,DOTLINE;

显示效果如下,其中黄色箭头是过均必牛线
fakename.png

但是今天打开软件,这根线突然显示就成了下方的线了,代码完全没改,但是显示完全不一样了
fakename.png



本帖寻求各位老师的解答

回复被采纳后将获得奖励 共享币 5 个 ,目前已有 2 个回复 我来解答
本主题由 任务系统 于 2022-1-18 10:05 审核通过

举报

使用道具 扔鸡蛋 回复

3532840
Lv.2

专栏

发表于 2022-1-18 14:40 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

3745336
Lv.3

专栏

发表于 2022-1-18 13:00 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表